Intermittent browser/base/content/test/performance/browser_urlbar_keyed_search_reflows.js | unexpected uninterruptible reflow / Unused expected reflow: [

RESOLVED FIXED in Firefox 57

Status

()

defect
P2
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: intermittent-bug-filer, Assigned: florian)

Tracking

({intermittent-failure})

unspecified
Firefox 57
Points:
---

Firefox Tracking Flags

(firefox57 fixed)

Details

(Whiteboard: [fxsearch])

Reporter

Description

2 years ago
treeherder
Filed by: archaeopteryx [at] coole-files.de

https://treeherder.mozilla.org/logviewer.html#?job_id=130688033&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/IQMfw-LpQeO_AzJogfj4gA/runs/0/artifacts/public/test_info/browser-chrome-chunked_errorsummary.log

FAIL | browser/base/content/test/performance/browser_urlbar_keyed_search_reflows.js | unexpected uninterruptible reflow [ "adjustHeight@chrome://global/content/bindings/autocomplete.xml:1252:32", "_invalidate/this._adjustHeightTimeout<@chrome://global/content/bindings/autocomplete.xml:1186:58", "setTimeout handler*_invalidate@chrome://global/content/bindings/autocomplete.xml:1186:41", "invalidate@chrome://global/content/bindings/autocomplete.xml:1164:11", "popup.invalidate@chrome://mochitests/content/browser/browser/base/content/test/performance/browser_urlbar_keyed_search_reflows.js:160:7", "notifyResults@jar:file:///Z:/task_1505314267/build/application/firefox/omni.ja!/components/UnifiedComplete.js:2240:5", "finishSearch@jar:file:///Z:/task_1505314267/build/application/firefox/omni.ja!/components/UnifiedComplete.js:2413:5", "startSearch/<@jar:file:///Z:/task_1505314267/build/application/firefox/omni.ja!/components/UnifiedComplete.js:2370:33", "promise callback*startSearch@jar:file:///Z:/task_1505314267/build/application/firefox/omni.ja!/components/UnifiedComplete.js:2363:5", "onInput@chrome://browser/content/urlbarBindings.xml:1318:17", "onxblinput@chrome://global/content/bindings/autocomplete.xml:650:9", "synthesizeKey@chrome://mochikit/content/tests/SimpleTest/EventUtils.js:883:7", "@chrome://mochitests/content/browser/browser/base/content/test/performance/browser_urlbar_keyed_search_reflows.js:173:7", "async*withReflowObserver@chrome://mochitests/content/browser/browser/base/content/test/performance/head.js:139:11", "async*@chrome://mochitests/content/browser/browser/base/content/test/performance/browser_urlbar_keyed_search_reflows.js:150:9", "Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:803:21", "TaskImpl_run@resource://gre/modules/Task.jsm:331:42", "promise callback*TaskImpl_handleResultValue@resource://gre/modules/Task.jsm:408:7", "TaskImpl_run@resource://gre/modules/Task.jsm:339:15", "TaskImpl@resource://gre/modules/Task.jsm:280:3", "asyncFunction@resource://gre/modules/Task.jsm:252:14", "Task_spawn@resource://gre/modules/Task.jsm:166:12", "Tester_execTest@chrome://mochikit/content/browser-test.js:794:9", "Tester.prototype.nextTest</<@chrome://mochikit/content/browser-test.js:694:7", "SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59", "" ] - false == true
Comment hidden (Intermittent Failures Robot)
Summary: Intermittent browser/base/content/test/performance/browser_urlbar_keyed_search_reflows.js | unexpected uninterruptible reflow → Intermittent browser/base/content/test/performance/browser_urlbar_keyed_search_reflows.js | unexpected uninterruptible reflow / Unused expected reflow: [
This and related bugs appear to have gone a bit nuts lately (nearly permafail on OSX/Win on Beta). Any chance you could take a look or pass it off to someone else, Marco?
Flags: needinfo?(mak77)
See Also: → 1401072, 1401432
How often these happen?
We recently (last few hours) modified the location bar, and bug 1356532 will further change it, so it's a moving target.
Unfortunately these tests are not stable enough.

I'd suggest for now to collect failures for a few days so we can analyze them and see the most common ones, it could help either understanding the issue or just do a single update. Now the test supports a minTimes property that allows to define a "bracket" or reflow counts rather than a fixed number of reflows. That can be used to avoid intermittent.
When you say permafail on Beta, you mean Beta 56 or Beta 57?
Flags: needinfo?(mak77) → needinfo?(ryanvm)
Priority: P5 → P2
Whiteboard: [fxsearch]

Comment 5

2 years ago
Pushed by florian@queze.net:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6985520d35f0
Remove the 'setTimeout handler' stack frames in browser_urlbar_keyed_search_reflows.js, rs=mak over IRC.
(In reply to Marco Bonardo [::mak] from comment #4)
> When you say permafail on Beta, you mean Beta 56 or Beta 57?

57
Flags: needinfo?(ryanvm)
Duplicate of this bug: 1401473

Comment 8

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6985520d35f0
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Comment hidden (Intermittent Failures Robot)

Comment 10

2 years ago
Pushed by florian@queze.net:
https://hg.mozilla.org/integration/mozilla-inbound/rev/250a752d5686
Intermittent browser_urlbar_keyed_search_reflows.js - reflow @ _handleOverflow was supposed to be hit 6 more times, r=mak over IRC.
Assignee

Comment 11

2 years ago
For clarity:

- my push in comment 5 was targeting the failures happening only on beta

- my push in comment 10 targets the failures that were seen on inbound and autoland in comment 9, with this failure message:
TEST-UNEXPECTED-FAIL | browser/base/content/test/performance/browser_urlbar_keyed_search_reflows.js | Unused expected reflow: [
   "_handleOverflow@chrome://global/content/bindings/autocomplete.xml",
   "handleOverUnderflow@chrome://global/content/bindings/autocomplete.xml",
   "_onChanged@chrome://global/content/bindings/autocomplete.xml",
   "_appendCurrentResult/<@chrome://global/content/bindings/autocomplete.xml",
 ]
 This reflow was supposed to be hit 6 more time(s).
Assignee: nobody → florian
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.