Closed Bug 1399675 Opened 2 years ago Closed 2 years ago

Sometimes images don't load or unload

Categories

(Core :: ImageLib, defect, P1)

x86
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1380649
Tracking Status
firefox57 --- affected

People

(Reporter: alberts, Unassigned)

References

Details

(Whiteboard: [gfx-noted])

Don't have a replicable example, but for a week or so I sometimes come back to a tab and instead of the images that had been loaded before I just see squares. Just now I was working in GDocs and when I switched to the file's "Version History" (link "All changes saved in Drive" next to "Help" menu item), the Back arrow and the printer on left as well as the up/down arrows on the right didn't load.
In all cases Shift+Reload fixed the issue.
Only happened for me on macOS 10.12, not on 10.11.
It happened again (Google Docs): https://screenshots.firefox.com/CjOCjSOoXduzYHV9/docs.google.com
Next to the star the folder icon should have loaded, but only appeared after reloading the page
Sounds like an image lib problem, which i think we've been doing some work on. Milan, can you help file this in the right component?
Flags: needinfo?(milan)
Component: General → ImageLib
Product: Firefox → Core
Andrew, this sounds like the problem Jeff's been seeing?
Flags: needinfo?(milan) → needinfo?(aosmond)
Priority: -- → P1
Whiteboard: [gfx-noted]
Yes this sounds like the same problem. Our image buffer is getting zapped to 0s (probably related to volatile buffers).
Flags: needinfo?(aosmond)
Just a quick update that it just happened on macOS 10.11 as well.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1380649
You need to log in before you can comment on or make changes to this bug.