dom/webauthn/u2f-hid-rs/src/manager.rs:10:5: unresolved import `platform::PlatformManager`

RESOLVED FIXED in Firefox 57

Status

()

defect
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jbeich, Assigned: jcj)

Tracking

({regression})

Trunk
mozilla57
Unspecified
FreeBSD
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 fixed)

Details

(Whiteboard: [webauthn])

Attachments

(1 attachment)

Reporter

Description

2 years ago
$ rustc -v --version
rustc 1.19.0
binary: rustc
commit-hash: unknown
commit-date: unknown
host: x86_64-unknown-freebsd
release: 1.19.0
LLVM version: 4.0


gmake[1]: Entering directory '/objdir/toolkit/library/rust'
force-cargo-library-build
env   RUSTC_BOOTSTRAP=1 RUSTFLAGS=' -C debuginfo=2 '  CARGO_TARGET_DIR=/objdir/toolkit/library RUSTC=/usr/local/bin/rustc MOZ_SRC=/mozilla-central MOZ_DIST=/objdir/dist LIBCLANG_PATH="/usr/local/llvm50/lib" CLANG_PATH="/usr/local/llvm50/bin/clang" PKG_CONFIG_ALLOW_CROSS=1 RUST_BACKTRACE=full MOZ_TOPOBJDIR=/objdir MOZ_CARGO_WRAP_LDFLAGS="-pthread -Wl,-z,noexecstack -Wl,-z,text -Wl,-z,relro -Wl,-rpath-link,/objdir/dist/bin -Wl,-rpath-link,/home/holo/.local/lib" MOZ_CARGO_WRAP_LD=" /usr/bin/cc -std=gnu99" CARGO_TARGET_X86_64_UNKNOWN_FREEBSD_LINKER=/mozilla-central/build/cargo-linker /usr/local/bin/cargo rustc  --release --frozen --manifest-path /mozilla-central/toolkit/library/rust/Cargo.toml --lib --target=x86_64-unknown-freebsd --features "servo bindgen quantum_render simd-accel no-static-ideograph-encoder-tables" --  -C lto
   Compiling u2fhid v0.1.0 (file:///mozilla-central/dom/webauthn/u2f-hid-rs)
   Compiling bindgen v0.29.0
   Compiling plane-split v0.6.0
   Compiling webrender_api v0.50.0 (file:///mozilla-central/gfx/webrender_api)
   Compiling malloc_size_of v0.0.1 (file:///mozilla-central/servo/components/malloc_size_of)
warning: unused macro definition
  --> /mozilla-central/dom/webauthn/u2f-hid-rs/src/util.rs:13:1
   |
13 | / macro_rules! try_or {
14 | |     ($val:expr, $or:expr) => {
15 | |         match $val {
16 | |             Ok(v) => { v }
...  |
19 | |     }
20 | | }
   | |_^
   |
   = note: #[warn(unused_macros)] on by default

error[E0432]: unresolved import `platform::PlatformManager`
  --> /mozilla-central/dom/webauthn/u2f-hid-rs/src/manager.rs:10:5
   |
10 | use platform::PlatformManager;
   |     ^^^^^^^^^^^^^^^^^^^^^^^^^ Maybe a missing `extern crate platform;`?

   Compiling selectors v0.19.0 (file:///mozilla-central/servo/components/selectors)
error: aborting due to previous error(s)

error: Could not compile `u2fhid`.
Reporter

Comment 1

2 years ago
../../dom/webauthn/Unified_cpp_dom_webauthn0.o: In function `mozilla::dom::U2FHIDTokenManager::U2FHIDTokenManager()':
objdir/dom/webauthn/Unified_cpp_dom_webauthn0.cpp:(.text._ZN7mozilla3dom18U2FHIDTokenManagerC2Ev+0x88): undefined reference to `rust_u2f_mgr_new'
/usr/bin/ld: ../../dom/webauthn/Unified_cpp_dom_webauthn0.o: relocation R_X86_64_PC32 against `rust_u2f_mgr_new' can not be used when making a shared object; recompile with -fPIC
/usr/bin/ld: final link failed: Bad value
c++: error: linker command failed with exit code 1 (use -v to see invocation)
Blocks: 1388851
Assignee

Comment 2

2 years ago
hmm; I guess we need to do the same as Android and add a blank stub for FreeBSD.
Priority: -- → P1
Whiteboard: [webauthn]
Comment hidden (obsolete)
Comment hidden (mozreview-request)
Assignee

Comment 6

2 years ago
Super-thanks Jan Beich for this patch!
Assignee: nobody → jjones
Status: NEW → ASSIGNED
(In reply to J.C. Jones [:jcj] from comment #2)
> hmm; I guess we need to do the same as Android and add a blank stub for
> FreeBSD.

Well, you need to think a bit wider.. outside of Tier1 there's not only FreeBSD :) The way it's fixed in your github PR is much nicer to us !

Comment 8

2 years ago
mozreview-review
Comment on attachment 8908441 [details]
Bug 1400066 - Gracefully handle unsupported platforms for U2F HID support

https://reviewboard.mozilla.org/r/180086/#review185334

Great stuff, much better.
Attachment #8908441 - Flags: review?(ttaubert) → review+

Comment 9

2 years ago
Pushed by ttaubert@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/07b93c7fec6c
Gracefully handle unsupported platforms for U2F HID support r=ttaubert
Keywords: checkin-needed

Comment 10

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/07b93c7fec6c
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.