Closed Bug 1400232 Opened 2 years ago Closed 2 years ago

Hide the menu button separator in compact mode

Categories

(Firefox :: Theme, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 57
Iteration:
57.3 - Sep 19
Tracking Status
firefox56 --- unaffected
firefox57 --- verified

People

(Reporter: valentina.ona, Assigned: dao)

References

(Blocks 1 open bug)

Details

(Keywords: polish, Whiteboard: [reserve-photon-visual])

Attachments

(2 files)

Attached image extra line.bmp
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID 20170914100122

[Affected version]: Nightly 57.0a1

[Affected platforms]: Windows 10 x64, Windows 7 x32, Windows 10 x64 Surface Pro4, Ubuntu 16.04 x64, Mac OS x 10.12

[Steps to reproduce]:

1. Launch Nightly 57.0a1
2. Set Density to Compact 
3. Observe the browser toolbar area

[Expected Result]: When Density is set to Compact, the separation line in front of the hamburger Menu is not displayed.

[Actual Result]:  The separation line is displayed.

[Notes]:
- Please see attached screenshot.
- Here are the mockups for this feature: https://mozilla.invisionapp.com/share/ENBBK0F9U#/screens/238616821
I think that's correct, it's a detail we missed.
Flags: qe-verify+
Keywords: polish
Priority: -- → P4
Whiteboard: [photon-visual][triage] → [photon-visual]
Whiteboard: [photon-visual] → [reserve-photon-visual]
QA Contact: ovidiu.boca
(In reply to Valentina Claudia Ona from comment #0)
> [Affected platforms]: Windows 10 x64, Windows 7 x32, Windows 10 x64 Surface
> Pro4, Ubuntu 16.04 x64, Mac OS x 10.12

> [Expected Result]: When Density is set to Compact, the separation line in
> front of the hamburger Menu is not displayed.

I can't reproduce this on Ubuntu and haven't seen it on Windows 10 either, but maybe I'm misunderstanding what this bug is about. Can you attach a screenshot of what you're seeing?

Also, can you please update the bug summary to something meaningful?
Flags: needinfo?(valentina.ona)
Flags: needinfo?(jhofmann)
Flags: needinfo?(valentina.ona)
Summary: An extra appears in compact density → An extra line appears in compact density
Please see the attachment in the description.
Okay, finally understood what this bug is about.
Flags: needinfo?(jhofmann)
Summary: An extra line appears in compact density → Hide the menu button separator in compact mode
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Priority: P4 → P1
Component: Toolbars and Customization → Theme
Iteration: --- → 57.3 - Sep 19
Comment on attachment 8908626 [details]
Bug 1400232 - Hide the menu button separator in compact mode.

https://reviewboard.mozilla.org/r/180292/#review185440
Attachment #8908626 - Flags: review?(jhofmann) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/925368197441
Hide the menu button separator in compact mode. r=johannh
https://hg.mozilla.org/mozilla-central/rev/925368197441
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Is it intentional that the space between the menu button and any icon to it's left is larger than between other icons?  It's almost as if you removed the separator but forgot to make the space smaller.
Verified as fixed on Nightly 57.0a1, Build ID 20170917220255 on Windows 10, Windows 10 Surface Pro4, Windows 7, Mac 10.12 and Ubuntu 16.04. 
I will mark this as fixed verified.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.