Closed Bug 1400305 Opened 4 years ago Closed 4 years ago

Redesign the Print Preview user-interface; current implementation has poor usability

Categories

(Core :: Print Preview, enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 133787
Tracking Status
firefox57 --- wontfix

People

(Reporter: grgwmsm, Unassigned)

References

Details

Attachments

(2 files)

Attached image Chrome-Print.png
User Agent: Mozilla/5.0 (Windows NT 5.1; WOW64; rv:55.0.2) Gecko/20100101 Firefox/55.0.2

Steps to reproduce:

Viewed Firefox's Print Preview of a webpage.


Actual results:

I was unable to get a useful Print Preview of the webpage (i.e., the UI was difficult to interact with, needed settings where not in easy reach, activating settings had no effect on the preview shown, overall the preview offers a poor experience).


Expected results:

Google Chrome has a great UI for its Print Preview. I would like to see Firefox copy Chrome's UI.

A couple points on why Chrome's is better:

1) often when I Print Preview, I want a quick assessment of how content is going to display/fit on individual pages. Chrome's UI shrinks the page-view to show an ENTIRE page. This allows quick assessments without having to click through settings, adjust a scrollbar etc.

2) In Chrome's UI, I can easily see and manipulate different settings (e.g., it is easy to enable/disable "Background graphics" and/or "Headers and footers"). Also, I can immediately see the effect of enabling/disabling these settings. This is not possible on Firefox. In Firefox, I have to drill into a settings dialog and make the change and even then I CANNOT see the effect in the Print Preview. Firefox's print dialog is very hard to understand and navigate and is basically just a terrible experience.

These are two examples, but there are more. It would be great to see a UI similar to Chrome's.

Screenshots uploaded for comparison.
Attached image Firefox-Print.png
Component: Untriaged → Print Preview
Product: Firefox → Core
Blocks: 1302489
Severity: normal → enhancement
Priority: -- → P3
Version: 57 Branch → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
Let's role this up with bug 133787. There are too many "redesign print preview" bugs and we should be discussing any redesign in a single place.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 133787
(In reply to Jonathan Watt [:jwatt] (needinfo? me) from comment #2)
> Let's role this up with bug 133787. There are too many "redesign print
> preview" bugs and we should be discussing any redesign in a single place.

Totally agree. Thanks for doing that.
You need to log in before you can comment on or make changes to this bug.