test_ext_startup_perf.js and test_ext_storage_telemetry.js are going to permafail when Gecko 57 is merged to Beta

VERIFIED FIXED in Firefox 56

Status

--
blocker
VERIFIED FIXED
a year ago
6 months ago

People

(Reporter: RyanVM, Assigned: mixedpuppy)

Tracking

unspecified
mozilla57

Firefox Tracking Flags

(firefox56 verified, firefox57+ verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
[Tracking Requested - why for this release]: Permafailing test that blocks merges of m-c to m-b ahead of next week's beta2 build.

https://treeherder.mozilla.org/logviewer.html#?job_id=131361613&repo=try
Flags: needinfo?(mixedpuppy)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 3

a year ago
mozreview-review
Comment on attachment 8908904 [details]
Bug 1400391 fix e10s xpcshell-test for remote webextensions,

https://reviewboard.mozilla.org/r/180522/#review185658

::: toolkit/components/extensions/test/xpcshell/head_remote.js:9
(Diff revision 2)
>  Services.prefs.setIntPref("dom.ipc.keepProcessesAlive.extension", 1);
> +
> +// We want to force enable e10s so we can test remote extensions
> +Services.prefs.setBoolPref("browser.tabs.remote.force-enable", true);
> +// This causes nsIXULRuntime.browserTabsRemoteAutostart to reset and force e10s
> +Services.prefs.setStringPref("e10s.rollout.cohort", "xpcshell-test");

Please also assert that we have the correct `WebExtensionPolicy.useRemoteWebExtensions` and `isExtensionProcess` values in head.js. We only caught this issue by accident this time.
Attachment #8908904 - Flags: review?(kmaglione+bmo) → review+
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 6

a year ago
mozreview-review
Comment on attachment 8908904 [details]
Bug 1400391 fix e10s xpcshell-test for remote webextensions,

https://reviewboard.mozilla.org/r/180522/#review185664

::: toolkit/components/extensions/test/xpcshell/head_test.js:4
(Diff revision 4)
> +do_check_eq(testEnv.expectRemote, WebExtensionPolicy.useRemoteWebExtensions, "useRemoteWebExtensions matches");
> +do_check_eq(!testEnv.expectRemote, WebExtensionPolicy.isExtensionProcess, "testing from extension process");

Nit: Please use `Assert.equal` rather than `do_check_eq`. Also, the expected value should be the second argument.
Comment hidden (mozreview-request)
(Reporter)

Updated

a year ago
Assignee: nobody → mixedpuppy
Flags: needinfo?(mixedpuppy)

Comment 8

a year ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ce09da537d44
fix e10s xpcshell-test for remote webextensions, r=kmag
status-firefox56: --- → ?
This is in theory going to affect 56 as well if we want to uplift the work from bug 1393150
(Assignee)

Comment 11

a year ago
I spent some time this morning and again this afternoon, trying to get any android build working locally.  mach bootstrap fails to install any android sdk/emulator that works on osx or linux.  not sure how to proceed on the android failures.
Flags: needinfo?(mixedpuppy)
Is there someone you can ask for help? (Best to ask now if they are in taipei/europe)
Flags: needinfo?(mixedpuppy)
The error here is:

{"thread": "ProcessReader", "level": "DEBUG", "pid": 926, "component": "mozdevice", "source": "Remote XPCShell", "time": 1505578606380, "action": "log", "message": "error: service name too long"}

Which seems to be happening because the additional head file makes the execution command too long.
Comment hidden (mozreview-request)
(Assignee)

Comment 15

a year ago
try running.  https://treeherder.mozilla.org/#/jobs?repo=try&revision=8e1f0fbc7662

assuming that passes we can land again.
Flags: needinfo?(mixedpuppy)
Comment hidden (mozreview-request)
(Assignee)

Comment 17

a year ago
and yet another try.  https://treeherder.mozilla.org/#/jobs?repo=try&revision=513216629623
which leaves me wondering why .only caused tests to fail.
tracking-firefox57: ? → +
OK can you request uplift now to m-r? (I realize this hasn't landed on m-c yet, but so that I don't forget later this morning)
Flags: needinfo?(mixedpuppy)
(Assignee)

Comment 20

a year ago
Comment on attachment 8908904 [details]
Bug 1400391 fix e10s xpcshell-test for remote webextensions,

Approval Request Comment
[Feature/Bug causing the regression]: 1393150
[User impact if declined]: followup test fixes for 1393150
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: 1393150
[Is the change risky?]: not this but see 1393150
[Why is the change risky/not risky?]: this one is a test-only patch
[String changes made/needed]: none
Flags: needinfo?(mixedpuppy)
Attachment #8908904 - Flags: approval-mozilla-release?
Comment on attachment 8908904 [details]
Bug 1400391 fix e10s xpcshell-test for remote webextensions,

From irc discussion, RyanVM says this should land and stick OK on m-r. 
Let's uplift so we can fix the the issue in bug 1393150
Attachment #8908904 - Flags: approval-mozilla-release? → approval-mozilla-release+

Comment 23

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4f2552380412
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox57: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
(Reporter)

Updated

a year ago
Status: RESOLVED → VERIFIED
status-firefox56: fixed → verified
status-firefox57: fixed → verified

Updated

6 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.