Closed Bug 1400408 Opened 2 years ago Closed 2 years ago

Add telemetry for the "More" link in "Pocket recommendations" title

Categories

(Firefox for Android :: General, enhancement, P1)

ARM
Android
enhancement

Tracking

()

RESOLVED FIXED
Firefox 58
Iteration:
1.30
Tracking Status
firefox57 --- fixed
firefox58 --- fixed

People

(Reporter: liuche, Assigned: liuche)

References

Details

(Whiteboard: [MobileAS])

Attachments

(2 files)

No description provided.
Assignee: nobody → liuche
Comment on attachment 8910548 [details]
Bug 1400408 - Fill in basic documentation of existing Pocket telemetry.

https://reviewboard.mozilla.org/r/181996/#review187348

Thanks for adding that section and cleaning up the docs.
Attachment #8910548 - Flags: review?(michael.l.comella) → review+
Comment on attachment 8910549 [details]
Bug 1400408 - Add telemetry for clicking on "MORE" link.

https://reviewboard.mozilla.org/r/181998/#review187354

::: mobile/android/docs/activitystreamtelemetry.rst:158
(Diff revision 1)
>  - "copy"
>  - "homescreen"
>  - "newtab" (private tab actions are collapsed into "newtab" telemetry due to our privacy guidelines)
>  - "dismiss"
>  - "delete"
> +- "more" ("MORE" link specifically for Top Stories, to open a link to more stories)

I don't think this is necessary: this list is values for the "item" key with regard to context menu interactions.
Attachment #8910549 - Flags: review?(michael.l.comella) → review+
Comment on attachment 8910549 [details]
Bug 1400408 - Add telemetry for clicking on "MORE" link.

https://reviewboard.mozilla.org/r/181998/#review187740

Looks like Category 2 data.

datareview+
Attachment #8910549 - Flags: review?(francois) → review+
Pushed by cliu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9a15512b9034
Fill in basic documentation of existing Pocket telemetry. r=mcomella
https://hg.mozilla.org/integration/autoland/rev/071a5773def4
Add telemetry for clicking on "MORE" link. r=francois,mcomella
https://hg.mozilla.org/mozilla-central/rev/9a15512b9034
https://hg.mozilla.org/mozilla-central/rev/071a5773def4
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Comment on attachment 8910548 [details]
Bug 1400408 - Fill in basic documentation of existing Pocket telemetry.

Approval Request Comment
[Feature/Bug causing the regression]: Didn't add documentation for Pocket telemetry
[User impact if declined]: no Pocket telemetry documentation, hard to uplift following patch w/ Pocket telemetry
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: documentation change
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: next patch in this bug
[Is the change risky?]: no
[Why is the change risky/not risky?]: only documentation changes
[String changes made/needed]: none
Attachment #8910548 - Flags: approval-mozilla-beta?
Comment on attachment 8910549 [details]
Bug 1400408 - Add telemetry for clicking on "MORE" link.

Approval Request Comment
[Feature/Bug causing the regression]: Missed 57 merge so didn't get this probe in
[User impact if declined]: No telemetry for if people try to see more Pocket stories
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: local testing
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: previous patch in this bug
[Is the change risky?]: no
[Why is the change risky/not risky?]: telemetry probe, adding documentation
[String changes made/needed]: none
Attachment #8910549 - Flags: approval-mozilla-beta?
Comment on attachment 8910549 [details]
Bug 1400408 - Add telemetry for clicking on "MORE" link.

Being of the beta cycle, taking the telemetry to help us making call.
Should be in 57b3
Attachment #8910549 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #8910548 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.