Foala editor spell checker does not work correctly

RESOLVED INVALID

Status

()

P3
normal
RESOLVED INVALID
11 months ago
10 months ago

People

(Reporter: andy2017, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(firefox57 wontfix, firefox58 fix-optional)

Details

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170824053838

Steps to reproduce:

Type several incorrect spelled words into Froala editor located here:

https://www.froala.com/wysiwyg-editor


Actual results:

Red underline is displayed only for a short time and is removed after more words are typed.


Expected results:

Red underline should remain on misspelled words even after you type other words.

Updated

11 months ago
Component: Untriaged → Spelling checker
Product: Firefox → Core

Comment 1

11 months ago
I am a developer at @Froala and I could provide more details about this. It appears the problem is coming from that fact that when some changes are made to the HTML via JS, spellchecker is no longer working. This should help to replicate the problem outside of the editor in a contenteditable field.

Comment 2

11 months ago
Debugging entire apps is often painful and time consuming. If you're willing, what would help the most is if you could cut things down until you have the smallest possible standalone testcase that reproduces the issue, and attach that here.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(stefan.neculai)
Priority: -- → P3
(Reporter)

Comment 3

11 months ago
(In reply to Jonathan Watt [:jwatt] from comment #2)
> Debugging entire apps is often painful and time consuming. If you're
> willing, what would help the most is if you could cut things down until you
> have the smallest possible standalone testcase that reproduces the issue,
> and attach that here.

Where is there an attach button?

Comment 4

11 months ago
I can provide a jsFiddle wih a contenteditable field alone. Let me just find some time in the following days.
Flags: needinfo?(stefan.neculai)

Comment 5

11 months ago
(In reply to Andy Bajka from comment #3)
> Where is there an attach button?

See the "Attach File" link at the bottom of the all the header fields (just above your first comment).

Comment 6

11 months ago
(In reply to Stefan from comment #4)
> I can provide a jsFiddle wih a contenteditable field alone. Let me just find
> some time in the following days.

Thanks. That would certainly be an improvement, although an attached testcase would be better (whoever debugs this will likely want that).

Updated

11 months ago
status-firefox57: --- → wontfix
status-firefox58: --- → fix-optional

Comment 7

11 months ago
Here is a jsFiddle: https://jsfiddle.net/udexf2js/. 

Steps to reproduce:
  1. Put cursor at the end of "Type here" text.
  2. Hit space.
  3. Type a misspelled word.
  4. Hit space.
  5. Type another misspelled word.


It appears that the main culprit for the problem is the normalize method. Commenting the line with this.normalize() would make the browser built-in spellchecker work correctly.
(Reporter)

Comment 8

10 months ago
Froala has worked out a solution to this issue and should be available in their latest version shortly.

Please close this bug report as it is no longer needed.

Thank you.
(Reporter)

Updated

10 months ago
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.