Closed Bug 1400863 Opened 2 years ago Closed 2 years ago

[Linux] Close button on the Tracking Protection tour popup is not scaled properly

Categories

(Toolkit :: Themes, defect, P1)

57 Branch
x86_64
Linux
defect

Tracking

()

VERIFIED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- verified
firefox58 --- verified

People

(Reporter: ashughes, Assigned: daleharvey)

References

Details

(Keywords: regression, Whiteboard: [reserve-photon-visual])

Attachments

(3 files)

The close (x) button is not scaled properly on the dialog that pops down to introduce users to Tracking Protection (see attached screenshot). I am using Firefox 57.0a1 20170917220255 on Fedora Linux 26 w/Gnome 3.24.2 on a Lenovo Thinkpad x260 with my screen at 1920x1080.
Johann, is this something that's trivial enough to do in 57 or should we put this on the backlog?
Flags: needinfo?(jhofmann)
Looks like a regression from bug 1385702 to me, we'll take a look at it.
Flags: needinfo?(jhofmann)
Whiteboard: [photon-visual][triage]
Blocks: 1385702
Keywords: regression
Component: Tracking Protection → Themes
Product: Firefox → Toolkit
Flags: qe-verify?
Priority: -- → P3
Whiteboard: [photon-visual][triage] → [reserve-photon-visual]
I couldn't reproduce this on Windows 10. Based on comment #0 I assume this is Linux-only.
Summary: Close button on the Tracking Protection tour popup is not scaled properly → [Linux] Close button on the Tracking Protection tour popup is not scaled properly
Also broken in osx although doesnt look exactly the same
Assignee: nobody → dharvey
Status: NEW → ASSIGNED
Priority: P3 → P1
Comment on attachment 8911119 [details]
Bug 1400863 - Fix tracking protection close icon size.

https://reviewboard.mozilla.org/r/182614/#review187870
Attachment #8911119 - Flags: review?(dao+bmo) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ed02545eb650
Fix tracking protection close icon size. r=dao
https://hg.mozilla.org/mozilla-central/rev/ed02545eb650
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Please request Beta approval on this when you get a chance.
Flags: needinfo?(dharvey)
Comment on attachment 8911119 [details]
Bug 1400863 - Fix tracking protection close icon size.

Approval Request Comment
[Feature/Bug causing the regression]: photon-visual polish
[User impact if declined]: Close buttons on tracking protection will be the wrong size
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: no
[Why is the change risky/not risky?]: small css change
[String changes made/needed]:
Flags: needinfo?(dharvey)
Attachment #8911119 - Flags: approval-mozilla-beta?
Flags: qe-verify? → qe-verify+
QA Contact: ovidiu.boca
Comment on attachment 8911119 [details]
Bug 1400863 - Fix tracking protection close icon size.

Fix an ugly icon, taking it.
Should be in 57b4 (gtb tomorrow Thursday)
Attachment #8911119 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I verified this on Mac OS X 10.10 and Ubuntu 16.04 with FF Nightly 58.0a1(2017-10-03) and FF beta 57.0b5 and I can confirm the fix.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.