Intermittent test_safe_browsing_warning_pages.py TestSafeBrowsingWarningPages.test_warning_pages | NoSuchElementException: Unable to locate element: getMeOutButton

RESOLVED FIXED in Firefox 57

Status

defect
P5
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: intermittent-bug-filer, Assigned: prathiksha)

Tracking

({intermittent-failure, regression})

Version 3
mozilla57
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 fixed)

Details

(Whiteboard: [stockwell fixed:other])

Attachments

(1 attachment)

Regression from bug 1363051. Francois or prathiksha, can you please take care of this regression? Thanks.
Flags: needinfo?(prathikshaprasadsuman)
Flags: needinfo?(francois)
Keywords: regression
(Assignee)

Updated

2 years ago
Assignee: nobody → prathikshaprasadsuman
Flags: needinfo?(prathikshaprasadsuman)
Flags: needinfo?(francois)
Comment hidden (Intermittent Failures Robot)
Can we please get this permanent failure fixed ASAP? It's very annoying and its very likely that the useful test will be disabled soon.
(Assignee)

Comment 4

2 years ago
(In reply to Henrik Skupin (:whimboo) from comment #3)
> Can we please get this permanent failure fixed ASAP? It's very annoying and
> its very likely that the useful test will be disabled soon.

Of course. I just got back to my computer. I'll fix it soon. :)
Comment hidden (mozreview-request)
Whiteboard: [stockwell needswork]

Comment 6

2 years ago
mozreview-review
Comment on attachment 8909785 [details]
Bug 1400992 - Fix test_safe_browsing_warning_pages.py.

https://reviewboard.mozilla.org/r/181272/#review186524

::: testing/firefox-ui/tests/functional/security/test_safe_browsing_warning_pages.py:89
(Diff revision 1)
>                                                           + "phishing-malware";
>              """)
>  
> -        button = self.marionette.find_element(By.ID, "reportButton")
> +        button = self.marionette.find_element(By.ID, 'seeDetailsButton')
>          button.click()
> +        time.sleep(1)

Why do you need sleep here? Please never use it in a test. Instead Wait().until() should be used if the expected element is not present right away.

::: testing/firefox-ui/tests/functional/security/test_safe_browsing_warning_pages.py:112
(Diff revision 1)
>          self.assertEquals(topic.text, "phishing-malware")
>  
>      def check_ignore_warning_button(self, unsafe_page):
> -        button = self.marionette.find_element(By.ID, 'ignoreWarningButton')
> +        button = self.marionette.find_element(By.ID, 'seeDetailsButton')
>          button.click()
> +        time.sleep(1)

Same here.

Can you please trigger try builds so that I can see what's going on here? Thanks.
Attachment #8909785 - Flags: review?(hskupin) → review-

Comment 7

2 years ago
mozreview-review
Comment on attachment 8909785 [details]
Bug 1400992 - Fix test_safe_browsing_warning_pages.py.

https://reviewboard.mozilla.org/r/181272/#review186526

I would also like to see a review from Francois regarding the behavior changes.
Attachment #8909785 - Flags: review?(francois)
Comment hidden (mozreview-request)
(Assignee)

Updated

2 years ago
Attachment #8909785 - Flags: review?(hskupin) → review?(francois)
Comment on attachment 8909785 [details]
Bug 1400992 - Fix test_safe_browsing_warning_pages.py.

https://reviewboard.mozilla.org/r/181272/#review186538

r=me with passing jobs on try.
Attachment #8909785 - Flags: review+

Comment 10

2 years ago
mozreview-review
Comment on attachment 8909785 [details]
Bug 1400992 - Fix test_safe_browsing_warning_pages.py.

https://reviewboard.mozilla.org/r/181272/#review186602
Attachment #8909785 - Flags: review?(francois) → review+
To get this bug fixed I went ahead and triggered the landing of the patch.

Comment 12

2 years ago
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6e57f448953d
Fix test_safe_browsing_warning_pages.py. r=francois,whimboo
Comment hidden (Intermittent Failures Robot)
https://hg.mozilla.org/mozilla-central/rev/6e57f448953d
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Comment hidden (Intermittent Failures Robot)
Ryan, due to the early merge of m-c to m-b it looks like this would be needed there to prevent the massive failures. Should we do an uplift or wait until the next merge?
Flags: needinfo?(ryanvm)
Flags: needinfo?(ryanvm)
Whiteboard: [stockwell disable-recommended] → [stockwell fixed:other]
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.