Closed Bug 1401085 Opened 2 years ago Closed 2 years ago

Different color is used for disabled back/forward arrows in toolbar (especially with Compact Density)

Categories

(Firefox :: Theme, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox57 --- verified
firefox58 --- verified

People

(Reporter: arai, Assigned: nhnt11)

References

(Blocks 1 open bug)

Details

(Whiteboard: [reserve-photon-visual])

Attachments

(2 files)

Steps to Reproduce:
  1. run Nightly 57.0a1 (2017-09-18) (64-bit) with clean profile
  2. start customize
  3. set to Compact Density
  4. finish customize

Actual result:
  while customizing, forward arrow is darker
  after customizing, back arrow is darker

Expected result:
  both arrows has same color
  (note that there's no history and both arrows are disabled)

actually the same color difference applies on Normal Density, but it's nor obvious on Compact Density, since there's no circle on back arrow.

also, the color difference also happens on Dark theme, with inverted brightness.
(In reply to Tooru Fujisawa [:arai] from comment #0)
> actually the same color difference applies on Normal Density, but it's nor
> obvious on Compact Density, since there's no circle on back arrow.

it's *more* obvious
I suspect they're getting different opacity because of 2 conflicting CSS rules.
Whiteboard: [photon-visual][triage]
Flags: qe-verify?
Priority: -- → P3
Whiteboard: [photon-visual][triage] → [reserve-photon-visual]
Assignee: nobody → nhnt11
Status: NEW → ASSIGNED
Iteration: --- → 57.3 - Sep 19
Priority: P3 → P1
Comment on attachment 8910536 [details]
Bug 1401085 - Make the opacity of the disabled back button consistent with other disabled toolbar buttons.

https://reviewboard.mozilla.org/r/181974/#review187528
Attachment #8910536 - Flags: review?(dao+bmo) → review+
Flags: qe-verify? → qe-verify+
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/1f5e6917b9af
Make the opacity of the disabled back button consistent with other disabled toolbar buttons. r=dao
QA Contact: ovidiu.boca
Iteration: 57.3 - Sep 19 → ---
Duplicate of this bug: 1402035
https://hg.mozilla.org/mozilla-central/rev/1f5e6917b9af
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Comment on attachment 8910536 [details]
Bug 1401085 - Make the opacity of the disabled back button consistent with other disabled toolbar buttons.

Approval Request Comment
[Feature/Bug causing the regression]: photon-visual polish
[User impact if declined]:  back button icon colour is not consistent with other toolbar buttons
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: no
[Why is the change risky/not risky?]: minor css change
[String changes made/needed]: none
Attachment #8910536 - Flags: approval-mozilla-beta?
Comment on attachment 8910536 [details]
Bug 1401085 - Make the opacity of the disabled back button consistent with other disabled toolbar buttons.

Photon polish, taking it.
Should be in 57b4!
Attachment #8910536 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I verify this issue using Latest Nightly 58.0a1 with Build ID 20171006100327 on Mac OS X 10.12.
I will mark this as verified fixed.
I also verified this issue using Latest Firefox Beta 57.0b9 and Nightly 58.0a1 with Build ID  20171016185129 on Windows 10 x64 and Mac OS 10 X 12
I can confirm the fix.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.