Closed Bug 1401117 Opened 7 years ago Closed 7 years ago

chrome.runtime.getBackgroundPage returns null

Categories

(WebExtensions :: Untriaged, defect)

55 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1329304

People

(Reporter: robbendebiene, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170807000000

Steps to reproduce:

Some of my Addon users reported this bug to me:
1. install Gesturefy (https://addons.mozilla.org/en-US/firefox/addon/gesturefy/)
2. open its option page


Actual results:

3. no text is visible (https://i.imgur.com/2EgU5n8.png)

Due to the users bug reports, this happens because: chrome.runtime.getBackgroundPage((object) =>{}) returns null

console errors (provided by users):
- https://user-images.githubusercontent.com/9383850/30580162-e9a67422-9d1b-11e7-9209-4da9427541a3.png
- https://i.imgur.com/1Tr16Qv.png

So I was not able to reproduce the bug, but one user reported it on Firefox 55.0.3 64 bit

more information: https://github.com/Robbendebiene/Gesturefy/issues/35#issuecomment-330452623


Expected results:

Normally the background-page-object is fetched properly/All settings are displayed
Component: General → WebExtensions: Untriaged
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.