Closed Bug 1401152 Opened 2 years ago Closed 2 years ago

Should disable 'add to overflow menu' in the customize mode *palette* context menu for flexible space

Categories

(Firefox :: Toolbars and Customization, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox57 --- verified
firefox58 --- verified

People

(Reporter: Gijs, Assigned: ewright)

References

(Blocks 1 open bug)

Details

(Whiteboard: [reserve-photon-structure])

Attachments

(1 file)

Erica noted in bug 1390313 comment #14 that you can try to add flexible spaces to the overflow menu from the customize mode palette, but that doesn't actually work. It not working is by design - the context menu item should be greyed out also in the palette.

The context menu for the toolbar already behaves correctly ("Pin to overflow menu" is greyed out).
Flags: qe-verify?
Flags: qe-verify? → qe-verify+
QA Contact: gwimberly
Assignee: nobody → ewright
Status: NEW → ASSIGNED
Priority: P4 → P1
Comment on attachment 8910958 [details]
Bug 1401152 - Disable 'add to overflow menu' in the customize mode *palette* context menu for flexible space.

https://reviewboard.mozilla.org/r/182418/#review187838

Nice, thanks!

::: browser/components/customizableui/CustomizeMode.jsm:2281
(Diff revision 1)
> +   let doc = event.target.ownerDocument;
> +   doc.querySelector(".customize-context-addToPanel").disabled = isFlexibleSpace;

Nit: you can use `event.target.querySelector` here, which will have fewer nodes to look at, and doesn't need you to get the document first. :-)
Attachment #8910958 - Flags: review?(gijskruitbosch+bugs) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/3ab791c98648
Disable 'add to overflow menu' in the customize mode *palette* context menu for flexible space. r=Gijs
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/3ab791c98648
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171002100134

I can reproduce this issue with Firefox Nightly 57.0a1, Build ID: 20170901220209 on Windows 8.1 x64.

This issue has been verified on latest Firefox Nightly Build ID: 20171002100134 on Windows 8.1 x64, Mac OS 10.12 and Ubuntu 14.04 and it's not reproducible. Now, when entering the Customization menu and right-clicking the Flexible Space button, the "Add to Overflow menu" option is grayed-out.
Status: RESOLVED → VERIFIED
Do we want to uplift that to 57?
Flags: needinfo?(ewright)
Yes Please,

Approval Request Comment
[Feature/Bug causing the regression]: photon having the flexible spacer in customize mode
[User impact if declined]: it is misleading, and appears to be added where it cannot be.
[Is this code covered by automated tests?]: generally yes; this specific part: no.
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]:
1. open customize mode
2. right click the flexible space in the palette / list of tools
3. view the "add to oveflow menu" option

ER: the "add to overflow menu" option is disabled and not clickable.
AR (prior to patch): the "add to overflow" option is available. When clicked the overflow icon animates.

[List of other uplifts needed for the feature/fix]: nope
[Is the change risky?]: no
[Why is the change risky/not risky?]: very small change to the relevant bit of code. The actual change is easy to test and verify
[String changes made/needed]: nope
Flags: needinfo?(ewright)
Comment on attachment 8910958 [details]
Bug 1401152 - Disable 'add to overflow menu' in the customize mode *palette* context menu for flexible space.

Approval Request Comment in comment 8. :-)
Attachment #8910958 - Flags: approval-mozilla-beta?
Comment on attachment 8910958 [details]
Bug 1401152 - Disable 'add to overflow menu' in the customize mode *palette* context menu for flexible space.

Photon related, Beta57+
Attachment #8910958 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I have reproduced the issue mentioned in comment 8 using an affected Firefox 57.0a1 build (BuildId:20170919220202).

I have verified that the issue is not reproducible using Firefox 57.0b7 (Build Id:20171009192146) on Windows 10 64bit, macOS 10.11.6 and Ubuntu 16.04 64bit.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.