Closed Bug 1401165 Opened 4 years ago Closed 4 years ago

stylo: Crash in Gecko_AttrHasPrefix

Categories

(Core :: CSS Parsing and Computation, defect, P3)

x86
Windows 10
defect

Tracking

()

VERIFIED WORKSFORME
Tracking Status
firefox57 --- affected

People

(Reporter: baffclan, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-54240389-613f-4640-9eae-cc6680170919.
=============================================================

Crashing Thread (28)
Frame 	Module 	Signature 	Source
0 	xul.dll 	Gecko_AttrHasPrefix 	layout/style/ServoBindings.cpp:1192
1 	xul.dll 	style::gecko::wrapper::{{impl}}::attr_matches 	servo/components/style/gecko/wrapper.rs:1782
2 	xul.dll 	selectors::matching::matches_simple_selector<style::gecko::wrapper::GeckoElement, closure> 	servo/components/selectors/matching.rs:654
3 	xul.dll 	selectors::matching::matches_complex_selector_internal<style::gecko::wrapper::GeckoElement, closure> 	servo/components/selectors/matching.rs:520
4 	xul.dll 	selectors::matching::matches_complex_selector<style::gecko::wrapper::GeckoElement, closure> 	servo/components/selectors/matching.rs:501
5 	xul.dll 	style::stylist::{{impl}}::match_revalidation_selectors::{{closure}}<style::gecko::wrapper::GeckoElement, closure> 	servo/components/style/stylist.rs:1434
6 	xul.dll 	style::traversal::compute_style<style::gecko::wrapper::GeckoElement> 	servo/components/style/traversal.rs:760
7 	xul.dll 	rayon_core::job::{{impl}}::execute<closure> 	third_party/rust/rayon-core/src/job.rs:139
8 	xul.dll 	rayon_core::registry::WorkerThread::wait_until<rayon_core::latch::CountLatch> 	third_party/rust/rayon-core/src/registry.rs:433
9 	xul.dll 	rayon_core::registry::in_worker<closure, ()> 	third_party/rust/rayon-core/src/registry.rs:588
10 	xul.dll 	rayon_core::job::{{impl}}::execute<rayon_core::latch::LockLatch, closure, ()> 	third_party/rust/rayon-core/src/job.rs:95
11 	xul.dll 	rayon_core::registry::WorkerThread::wait_until<rayon_core::latch::CountLatch> 	third_party/rust/rayon-core/src/registry.rs:433
12 	xul.dll 	std::sys_common::backtrace::__rust_begin_short_backtrace<closure, ()> 	src/libstd/sys_common/backtrace.rs:133
13 	xul.dll 	alloc::boxed::{{impl}}::call_box<(), closure> 	src/liballoc/boxed.rs:647
14 	xul.dll 	std::sys::imp::thread::{{impl}}::new::thread_start 	src/libstd/sys/windows/thread.rs:50
15 	kernel32.dll 	BaseThreadInitThunk 	
16 	ntdll.dll 	RtlUserThreadStart 	



Application Basics: 
Name: Firefox
Version: 57.0a1
Build ID: 20170918220054
Update Channel: nightly
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
OS: Windows_NT 10.0
Component: Layout → CSS Parsing and Computation
Summary: Crash in Gecko_AttrHasPrefix → stylo: Crash in Gecko_AttrHasPrefix
Could you share the URL on which this crash occurred?
I can't find any obvious reason for this crash, will investigate more later.
Flags: needinfo?(baffclan)
Priority: -- → P3
I opened Pootle server for LibreOffice.
https://translations.documentfoundation.org/ja/

There is no reproducibility.
Flags: needinfo?(baffclan)
On that site there is a rule with a selector: [class^="icon-"].  I can't reproduce, and don't know why we should be generating EXCEPTION_ILLEGAL_INSTRUCTION in there.
There's only ever been that one crash report.  Resolving WORKSFORME.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
-> verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.