Closed Bug 1401175 Opened 3 years ago Closed 3 years ago

Default Firefox 57 Theme Broken in MacOS High Sierra GM

Categories

(Core :: Widget: Cocoa, defect)

57 Branch
x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1398582

People

(Reporter: charlie.siegel, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13) AppleWebKit/604.1.38 (KHTML, like Gecko) Version/11.0 Safari/604.1.38

Steps to reproduce:

Open Firefox Nightly (57).  Look at UI - there is a grey bar directly above the white toolbar portion of the UI.  The corners of the top of the UI have white slivers on them.  The active tab shows the title of the tab in both the tab but also in the top center of the window.

I am on the GM of MacOS High Sierra.  I have repeatedly continue to update to the latest nightly build in hopes this would clear, but it hasn't.  I've deleted my profile and caches repeatedly in an attempt to solve this.  I also just logged into a different MacOS user account on this machine that has never run Firefox at all and the issue still appears there.

I've attached a screenshot, and for some reason the actual results are inverted.  The portion in the shot you're seeing as dark grey is actually lightly grey, and the light grey is black.


Actual results:

The theme is not displaying correctly.  This began about 2 weeks ago for me.


Expected results:

The theme should have been displayed properly.  There shouldn't have been a grey bar, white notches in the corner, and the title should only be displayed on the tab.
Iteration: --- → 57.3 - Sep 19
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86
Hardware: x86 → x86_64
Charlie - Thanks for reporting.

Bug 1400057 is on file for the white corners. A try build was just posted and is building that we can test to see if it resolves the issue.

Bug 1398582 is the garbled tab bar, which I think represents what is posted in your screenshot. That also has a patch under review.

So it appears what you describe is a duplicate of those two bugs.
Component: Untriaged → Widget: Cocoa
Product: Firefox → Core
Great, thank you!
Removing tracking flags and duping to the more prominent bug, Bug 1398582.
Status: UNCONFIRMED → RESOLVED
Iteration: 57.3 - Sep 19 → ---
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1398582
You need to log in before you can comment on or make changes to this bug.