Closed Bug 1401523 Opened 2 years ago Closed 2 years ago

Bookmark items are missing vertical padding on Windows

Categories

(Firefox :: Theme, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 57
Iteration:
57.3 - Sep 19
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- verified
firefox58 --- verified

People

(Reporter: johannh, Assigned: johannh)

References

Details

(Keywords: regression, Whiteboard: [reserve-photon-visual])

Attachments

(1 file)

No description provided.
Iteration: --- → 57.3 - Sep 19
Flags: qe-verify?
Comment on attachment 8910250 [details]
Bug 1401523 - Add 1px vertical padding to bookmark items.

https://reviewboard.mozilla.org/r/181740/#review187088

Tested on Windows 10, it appears coherent with the mock-ups.
Attachment #8910250 - Flags: review?(mak77) → review+
As a side note, bug 1391593 moved the bookmarks up by 1px compared to the mock-up, it may be wanted or not. Based on that bug it should be centered so it's wanted.

As a final note, 2px 4px (insteaf of 1px 4px) of padding looks many times better. But that's something for Stephen to evaluate :)
Duplicate of this bug: 1401535
Duplicate of this bug: 1401494
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5e19b6a153a6
Add 1px vertical padding to bookmark items. r=mak
So I have tested the patch and looks perfect for all densities. All of the sudden it solves all remaining "issues" from bug 1388794. So bug 1388794 is now completely fixed. Thanks!
The biggest visible issue for Bookmark toolbar remains in bug 1363028, which is unfortunately without activity for a month. It is sad since for example folder icons are currently still from Australis era.
https://hg.mozilla.org/mozilla-central/rev/5e19b6a153a6
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Flags: qe-verify? → qe-verify+
QA Contact: ovidiu.boca
I verified this issue on Windows 10 x64 and Windows 7 x64 using Nightly 58.0a1 and Firefox Beta 57.0b3 with Build ID 20170926220106 and Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0.
I will mark this as verified fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.