Open Bug 1401570 Opened 4 years ago Updated 7 days ago

Intermittent Loading initial page https://web-platform.test:8443/testharness_runner.html failed. Ensure that the there are no other programs bound to this port and that your firewall rules or network setup does not prevent access.\eTraceback

Categories

(Testing :: web-platform-tests, defect, P5)

Version 3
defect

Tracking

(Not tracked)

REOPENED

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure)

Filed by: archaeopteryx [at] coole-files.de

https://treeherder.mozilla.org/logviewer.html#?job_id=132202299&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/Kb_RM-BpSoG8G7avOAgANg/runs/0/artifacts/public/logs/live_backing.log

12:39:08     INFO - TEST-START | /_mozilla/html/semantics/scripting-1/the-script-element/mixed-content-import.https.html
12:39:08     INFO - Clearing pref dom.moduleScripts.enabled
12:39:08     INFO - Setting pref dom.moduleScripts.enabled (true)
12:39:08     INFO - PID 1688 | ++DOMWINDOW == 27 (1FE5BC00) [pid = 1688] [serial = 27] [outer = 18B10800]
12:39:08     INFO - PID 1688 | [1688, Main Thread] WARNING: stylo: Web Components not supported yet: file z:/build/build/src/dom/base/nsDocument.cpp, line 6391
12:39:08     INFO - PID 1688 | [1688, Main Thread] WARNING: stylo: Web Components not supported yet: file z:/build/build/src/dom/base/nsDocument.cpp, line 6391
12:39:08     INFO - PID 1688 | [1688, Main Thread] WARNING: attempt to modify an immutable nsStandardURL: file z:/build/build/src/netwerk/base/nsStandardURL.cpp, line 1827
12:39:08 CRITICAL - Loading initial page https://web-platform.test:8443/testharness_runner.html failed. Ensure that the there are no other programs bound to this port and that your firewall rules or network setup does not prevent access.\eTraceback (most recent call last):
12:39:08 CRITICAL -   File "Z:\task_1505904940\build\tests\web-platform\tests\tools\wptrunner\wptrunner\executors\executormarionette.py", line 137, in load_runner
12:39:08 CRITICAL -     self.marionette.navigate(url)
12:39:08 CRITICAL -   File "Z:\task_1505904940\build\venv\lib\site-packages\marionette_driver\marionette.py", line 1644, in navigate
12:39:08 CRITICAL -     self._send_message("get", {"url": url})
12:39:08 CRITICAL -   File "Z:\task_1505904940\build\venv\lib\site-packages\marionette_driver\decorators.py", line 23, in _
12:39:08 CRITICAL -     return func(*args, **kwargs)
12:39:08 CRITICAL -   File "Z:\task_1505904940\build\venv\lib\site-packages\marionette_driver\marionette.py", line 759, in _send_message
12:39:08 CRITICAL -     self._handle_error(err)
12:39:08 CRITICAL -   File "Z:\task_1505904940\build\venv\lib\site-packages\marionette_driver\marionette.py", line 792, in _handle_error
12:39:08 CRITICAL -     raise errors.lookup(error)(message, stacktrace=stacktrace)
12:39:08 CRITICAL - UnknownException: Reached error page: about:neterror?e=nssFailure2&u=https%3A//web-platform.test%3A8443/testharness_runner.html&c=UTF-8&f=regular&d=An%20error%20occurred%20during%20a%20connection%20to%20web-platform.test%3A8443.%0A%0ASSL%20peer%20reports%20incorrect%20Message%20Authentication%20Code.%0A%0AError%20code%3A%20%3Ca%20id%3D%22errorCode%22%20title%3D%22SSL_ERROR_BAD_MAC_ALERT%22%3ESSL_ERROR_BAD_MAC_ALERT%3C/a%3E%0A
12:39:08 CRITICAL - stacktrace:
12:39:08 CRITICAL - 	WebDriverError@chrome://marionette/content/error.js:239:5
12:39:08 CRITICAL - 	UnknownError@chrome://marionette/content/error.js:537:5
12:39:08 CRITICAL - 	handleReadyState@chrome://marionette/content/listener.js:313:21
12:39:08 CRITICAL - 	handleEvent@chrome://marionette/content/listener.js:281:9
https://treeherder.mozilla.org/logviewer.html#?job_id=175622236&repo=autoland
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Duplicate of this bug: 1189308
https://wiki.mozilla.org/Bug_Triage#Intermittent_Test_Failure_Cleanup
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → INCOMPLETE
Fail reappeared on m-central

Log link: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=219548506&repo=mozilla-central&lineNumber=1247

Log snippet:

[task 2019-01-02T10:26:31.152Z] 10:26:31 CRITICAL -   File "/builds/worker/workspace/build/tests/web-platform/tests/tools/wptrunner/wptrunner/testrunner.py", line 141, in start_runner
[task 2019-01-02T10:26:31.152Z] 10:26:31 CRITICAL -     runner.run()
[task 2019-01-02T10:26:31.152Z] 10:26:31 CRITICAL -   File "/builds/worker/workspace/build/tests/web-platform/tests/tools/wptrunner/wptrunner/testrunner.py", line 86, in run
[task 2019-01-02T10:26:31.152Z] 10:26:31 CRITICAL -     self.setup()
[task 2019-01-02T10:26:31.153Z] 10:26:31 CRITICAL -   File "/builds/worker/workspace/build/tests/web-platform/tests/tools/wptrunner/wptrunner/testrunner.py", line 73, in setup
[task 2019-01-02T10:26:31.153Z] 10:26:31 CRITICAL -     self.executor.setup(self)
[task 2019-01-02T10:26:31.153Z] 10:26:31 CRITICAL -   File "/builds/worker/workspace/build/tests/web-platform/tests/tools/wptrunner/wptrunner/executors/executormarionette.py", line 642, in setup
[task 2019-01-02T10:26:31.153Z] 10:26:31 CRITICAL -     self.protocol.testharness.load_runner(self.last_environment["protocol"])
[task 2019-01-02T10:26:31.153Z] 10:26:31 CRITICAL -   File "/builds/worker/workspace/build/tests/web-platform/tests/tools/wptrunner/wptrunner/executors/executormarionette.py", line 131, in load_runner
[task 2019-01-02T10:26:31.154Z] 10:26:31 CRITICAL -     self.dismiss_alert(lambda: self.marionette.navigate(url))
[task 2019-01-02T10:26:31.154Z] 10:26:31 CRITICAL -   File "/builds/worker/workspace/build/tests/web-platform/tests/tools/wptrunner/wptrunner/executors/executormarionette.py", line 180, in dismiss_alert
[task 2019-01-02T10:26:31.154Z] 10:26:31 CRITICAL -     f()
[task 2019-01-02T10:26:31.154Z] 10:26:31 CRITICAL -   File "/builds/worker/workspace/build/tests/web-platform/tests/tools/wptrunner/wptrunner/executors/executormarionette.py", line 131, in <lambda>
[task 2019-01-02T10:26:31.154Z] 10:26:31 CRITICAL -     self.dismiss_alert(lambda: self.marionette.navigate(url))
[task 2019-01-02T10:26:31.154Z] 10:26:31 CRITICAL - AttributeError: 'MarionetteTestharnessProtocolPart' object has no attribute 'marionette'
[task 2019-01-02T10:26:31.155Z] 10:26:31 CRITICAL - 
[task 2019-01-02T10:26:31.155Z] 10:26:31     INFO - Closing logging queue
[task 2019-01-02T10:26:31.155Z] 10:26:31     INFO - queue closed
[task 2019-01-02T10:26:31.155Z] 10:26:31  WARNING - Command left in remote_queue during cleanup: u'stop', ()
[task 2019-01-02T10:26:31.821Z] 10:26:31     INFO - Got 0 unexpected results
[task 2019-01-02T10:26:31.821Z] 10:26:31     INFO - SUITE-END | took 385s
[task 2019-01-02T10:26:31.888Z] 10:26:31     INFO - Closing logging queue
[task 2019-01-02T10:26:31.889Z] 10:26:31     INFO - queue closed
[task 2019-01-02T10:26:31.889Z] 10:26:31 CRITICAL - Test harness output was not a valid structured log message: 
[task 2019-01-02T10:26:31.889Z] 10:26:31 CRITICAL - Traceback (most recent call last):
[task 2019-01-02T10:26:31.889Z] 10:26:31 CRITICAL - Test harness output was not a valid structured log message: 
[task 2019-01-02T10:26:31.890Z] 10:26:31 CRITICAL -   File "/usr/lib/python2.7/multiprocessing/queues.py", line 268, in _feed
[task 2019-01-02T10:26:31.890Z] 10:26:31 CRITICAL - Test harness output was not a valid structured log message: 
[task 2019-01-02T10:26:31.890Z] 10:26:31 CRITICAL -     send(obj)
[task 2019-01-02T10:26:31.890Z] 10:26:31 CRITICAL - Test harness output was not a valid structured log message: 
[task 2019-01-02T10:26:31.890Z] 10:26:31 CRITICAL - IOError: [Errno 32] Broken pipe
[task 2019-01-02T10:26:32.256Z] 10:26:32     INFO - Return code: 0
[task 2019-01-02T10:26:32.257Z] 10:26:32 CRITICAL - # TBPL FAILURE #
[task 2019-01-02T10:26:32.257Z] 10:26:32  WARNING - setting return code to 2
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → INCOMPLETE
Status: REOPENED → RESOLVED
Closed: 3 years ago2 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 2 years ago7 months ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 7 months ago5 months ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 5 months ago26 days ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
You need to log in before you can comment on or make changes to this bug.