Closed Bug 1401724 Opened 2 years ago Closed 7 months ago

Jitter when presenting on HTC Vive Headsets

Categories

(Core :: WebVR, defect, P2)

55 Branch
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox56 --- affected
firefox57 --- affected
firefox58 --- affected

People

(Reporter: dmarcos, Unassigned, NeedInfo)

References

Details

This affects Firefox release and Nightly at the time of filing this bug. The jitter reproduces consistently across the following demos so it seems to be content independent:

1 (A-Frame) https://aframe.io/a-painter/
2 (THREE.js) https://threejs.org/examples/#webvr_vive_paint
3 (WebGL) https://webvr.info/samples/XX-vr-controllers.html

A good way to observe is on the controllers by switching back and forth between Steam Home and Firefox.
See Also: → 1392216
The multithreading work in Bug 1392216 will likely fix this.
Priority: -- → P2
After Bug 1392216 is landed, it is possible to resolve this jitter problem. Please help me have a try, thanks. :dmarcos.
Flags: needinfo?(dmarcos)
QA Contact: cristian.comorasu

There haven't been more reports of this kind of jitter in 2 years. Please feel free to re-open and/or NI me if you find a test case that can reproduce this currently.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.