Closed Bug 1401779 Opened 2 years ago Closed 2 years ago

Use new version of onCreateView

Categories

(Firefox for Android :: General, enhancement)

All
Android
enhancement
Not set

Tracking

()

RESOLVED FIXED
Firefox 57
Tracking Status
firefox57 --- fixed

People

(Reporter: mcomella, Assigned: mcomella)

References

Details

Attachments

(1 file)

The version we're currently using states [1]:

This implementation does nothing and is for pre-HONEYCOMB apps. Newer apps should use onCreateView(View, String, Context, AttributeSet).

---

We no longer support pre-HC devices so we should move to the new method.

[1]: https://developer.android.com/reference/android/app/Activity.html#onCreateView(java.lang.String,%20android.content.Context,%20android.util.AttributeSet)
Assignee: nobody → michael.l.comella
Comment on attachment 8910531 [details]
Bug 1401779: Use HC+ Actvitiy.onCreateView.

https://reviewboard.mozilla.org/r/181966/#review187356

Since we're now r16+, I don't see any reason to not use the newer version of onCreateView. lgtm

::: mobile/android/base/java/org/mozilla/gecko/BrowserApp.java:363
(Diff revision 1)
>      private final Set<String> mStreamIconLayoutFailedRequestCache = StreamOverridablePageIconLayout.newFailedRequestCache();
>  
>      private boolean mHasResumed;
>  
>      @Override
> -    public View onCreateView(final String name, final Context context, final AttributeSet attrs) {
> +    public View onCreateView(final View parent, final String name, final Context context, final AttributeSet attrs) {

Saw a note that parent might be null, but it looks like we don't use parent anyway.
Attachment #8910531 - Flags: review?(liuche) → review+
Pushed by cliu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/22f5e644534b
Use HC+ Actvitiy.onCreateView. r=liuche
https://hg.mozilla.org/mozilla-central/rev/22f5e644534b
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Duplicate of this bug: 1377819
You need to log in before you can comment on or make changes to this bug.