Closed Bug 1401922 Opened 2 years ago Closed 2 years ago

[Bug 1400537] Crash in mozilla::MediaFormatReader::DecoderFactory::Wrapper::Init. Part2

Categories

(Core :: Audio/Video: Playback, defect)

57 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 + fixed
firefox58 --- fixed

People

(Reporter: jya, Assigned: jya)

References

Details

(Keywords: regression)

Crash Data

Attachments

(2 files)

Bug 1400537 didn't fully fixed the regressions introduced in bug 1400537.

This bug will have another go at it
Comment on attachment 8910703 [details]
Bug 1401922 - P1. Ensure an error is returned when no decoder could be created.

https://reviewboard.mozilla.org/r/182162/#review187544

Thanks!

::: dom/media/MediaFormatReader.cpp:778
(Diff revision 1)
>    }
>  
>    if (aData.mDecoder) {
>      return NS_OK;
>    }
>  

Maybe we could add an assertion here to make sure the result won't be unexpectedly changed to NS_OK when creating fail?
Attachment #8910703 - Flags: review?(alwu) → review+
Comment on attachment 8910704 [details]
Bug 1401922 - P2. Only set error when non handled.

https://reviewboard.mozilla.org/r/182164/#review187546
Attachment #8910704 - Flags: review?(alwu) → review+
Comment on attachment 8910703 [details]
Bug 1401922 - P1. Ensure an error is returned when no decoder could be created.

https://reviewboard.mozilla.org/r/182162/#review187544

> Maybe we could add an assertion here to make sure the result won't be unexpectedly changed to NS_OK when creating fail?

good point. making it even a release_assert
[Tracking Requested - why for this release]: recent regression in 57. Fairly certain these changes now fix it for good
Has Regression Range: --- → yes
Version: 55 Branch → 57 Branch
Pushed by jyavenard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/907df99df1bb
P1. Ensure an error is returned when no decoder could be created. r=alwu
https://hg.mozilla.org/integration/autoland/rev/6d14932fb843
P2. Only set error when non handled. r=alwu
https://hg.mozilla.org/mozilla-central/rev/907df99df1bb
https://hg.mozilla.org/mozilla-central/rev/6d14932fb843
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Please request uplift to beta when you get a chance.
For information, there are 112 crashes for 17 installations in 57.0b0 (dev edition) for signature 'mozilla::EMEDecryptor::Init'.
Flags: needinfo?(jyavenard)
One crash on nightly with the 20170921220243 build, none since, as far as I can tell.
Comment on attachment 8910703 [details]
Bug 1401922 - P1. Ensure an error is returned when no decoder could be created.

Approval Request Comment
[Feature/Bug causing the regression]: 1397141
[User impact if declined]: Crash
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: No crashes since fix went in in 58
[Needs manual test from QE? If yes, steps to reproduce]: I assume that if you attempt to play a DRM encumbered video when DRM is disabled you could reproduce it.
[List of other uplifts needed for the feature/fix]: both changes to be uplifted
[Is the change risky?]: no
[Why is the change risky/not risky?]: reversing to previous code logic.
[String changes made/needed]: none
Flags: needinfo?(jyavenard)
Attachment #8910703 - Flags: approval-mozilla-beta?
Comment on attachment 8910703 [details]
Bug 1401922 - P1. Ensure an error is returned when no decoder could be created.

Fix a crash, taking it.
Should be in 57b4 (gtb tomorrow Thursday)
Attachment #8910703 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #8910704 - Flags: approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.