Font size of One-Click Search Engines list items are small in about:preferences#search

VERIFIED FIXED in Firefox 57

Status

()

defect
P3
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: arai, Assigned: rickychien)

Tracking

({regression})

unspecified
Firefox 58
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57- verified, firefox58 verified)

Details

(Whiteboard: [photon-preference])

Attachments

(2 attachments)

Reporter

Description

2 years ago
Steps to reproduce:
  1. open Nightly 58.0a1 (2017-09-21) (64-bit) with clean profile on macOS
  2. open about:preferences#search
  3. scroll to "One-Click Search Engines" section

Actual result:
  font size for the list items are small, including row headers

Expected result:
  they have same font size as other area of the page
[Tracking Requested - why for this release]: minor visual regression

This is caused by http://searchfox.org/mozilla-central/rev/f6dc0e40b51a37c34e1683865395e72e7fca592c/toolkit/themes/shared/in-content/common.inc.css#907

Ricky, can you take a look at this?
Blocks: 1397121
Flags: needinfo?(rchien)
Priority: -- → P5
Whiteboard: [photon-preference][triage]
Assignee: nobody → rchien
Flags: needinfo?(rchien)
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)
Your patch causes the inverse variant of this bug on Linux: it makes the tree header and items too big.

Comment 4

2 years ago
mozreview-review
Comment on attachment 8912700 [details]
Bug 1402244 - Recover broken treecol & treechildren font-size

https://reviewboard.mozilla.org/r/184028/#review189270

::: toolkit/themes/shared/in-content/common.inc.css:902
(Diff revision 1)
>  xul|treecol > xul|label.treecol-text {
> -  font-size: 1rem;
> +  font-size: 1.25rem;
>  }
>  
>  xul|treechildren {
> -  font-size: 1rem !important;
> +  font-size: 1.25rem !important;
>  }

What happens if you remove these rules?

Comment 5

2 years ago
mozreview-review
Comment on attachment 8912700 [details]
Bug 1402244 - Recover broken treecol & treechildren font-size

https://reviewboard.mozilla.org/r/184028/#review189290

Marking r- due to comment #3.
Attachment #8912700 - Flags: review?(jaws) → review-
Priority: P5 → P3
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Assignee

Comment 8

2 years ago
mozreview-review
Comment on attachment 8912700 [details]
Bug 1402244 - Recover broken treecol & treechildren font-size

https://reviewboard.mozilla.org/r/184028/#review189534

::: toolkit/themes/shared/in-content/common.inc.css:902
(Diff revision 1)
>  xul|treecol > xul|label.treecol-text {
> -  font-size: 1rem;
> +  font-size: 1.25rem;
>  }
>  
>  xul|treechildren {
> -  font-size: 1rem !important;
> +  font-size: 1.25rem !important;
>  }

Yep, you're right. Removing these rules can recover the font-size and apply platform specific size. It looks much better now.
Patch has updated, please check it again.
Whiteboard: [photon-preference][triage] → [photon-preference]
Severity: minor → normal
Given that this was triaged as a P3, I doubt that this will make it into 57. Untracked for the same reason.

Comment 11

2 years ago
mozreview-review
Comment on attachment 8912700 [details]
Bug 1402244 - Recover broken treecol & treechildren font-size

https://reviewboard.mozilla.org/r/184028/#review189986
Attachment #8912700 - Flags: review?(jaws) → review+

Comment 12

2 years ago
Pushed by rchien@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5a9b49e80fff
Recover broken treecol & treechildren font-size r=jaws
Comment on attachment 8912700 [details]
Bug 1402244 - Recover broken treecol & treechildren font-size

Approval Request Comment
[Feature/Bug causing the regression]: a regression patch from bug 1357306
[User impact if declined]: minor visual regression
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]: see description
[List of other uplifts needed for the feature/fix]: no
[Is the change risky?]: minor 
[Why is the change risky/not risky?]: minor visual regression
[String changes made/needed]: none
Attachment #8912700 - Flags: approval-mozilla-beta?
(In reply to Ritu Kothari (:ritu) from comment #10)
> Given that this was triaged as a P3, I doubt that this will make it into 57.
> Untracked for the same reason.

We're using P3 for tracking project progress velocity and release forecast. We recommend that this should be fixed in fx57 to make 57 better. Thanks
https://hg.mozilla.org/mozilla-central/rev/5a9b49e80fff
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58

Comment 16

2 years ago
Build ID: 20171001220301
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

Verified as fixed on Firefox Nightly 58.0a1 on Windows 10 x 64, Windows 7 x32, Mac OS X 10.12 and Ubuntu 16.04 x64.
Comment on attachment 8912700 [details]
Bug 1402244 - Recover broken treecol & treechildren font-size

Fix a visual regression, taking it.
Should be in 57b5
Attachment #8912700 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+

Comment 19

2 years ago
Build ID: 20171002181526
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Verified as fixed on Firefox Beta 57.0b5 on Windows 10 x 64, Windows 7 x32, Mac OS X 10.12 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: qe-verify+
QA Contact: hani.yacoub
You need to log in before you can comment on or make changes to this bug.