Closed Bug 1402453 Opened 7 years ago Closed 7 years ago

Clicking twice the search icon with mouse makes the search bar deselected in about:newtab

Categories

(Firefox :: New Tab Page, defect)

57 Branch
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- verified
firefox58 --- verified

People

(Reporter: maruf.rahman.95, Assigned: Mardak)

References

Details

(Keywords: regression)

Build ID   : 20170921100141
User Agent : Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 
             Firefox/57.0
OS         : Windows 7, 64 Bit!

Steps to Reproduce : 
          
             1. Open Firefox Nightly and go to about:newtab
             2. Then select the search option 
             3. Beside the string 'search the web' you will see the search icon
             4. Click twice the search icon with mouse
             

Actual result      :

             The focused search bar flickers and the search bar gets deselected 

Expected result    : 
  
             The focused search bar should not flicker and the search bar should not get deselected.
With activity stream disabled, clicking the search icon would de-focus the search bar (which may or may not be right overall), in any case, you don't get the flickering that you do with activity stream.

So I suspect this is an issue with activity stream and how they are managing focus for it (though we may need to fix the focussing in the search.xml) - moving to the new tab component for more diagnosis.
Component: Search → Activity Streams: Newtab
Keywords: regression
Ah it's probably because the icon is a <label> which moves focus from it to the input box.
The flickering was fixed by https://github.com/mozilla/activity-stream/pull/3588 to be uplifted via bug 1403215.

The deselecting I believe is just how labels work as Standard8 pointed out in comment 1 disabled. If it were text, the text would end up being selected instead of the input:

data:text/html,<label for="i">Label</label><input id="i"/>
Assignee: nobody → edilee
Blocks: 1403215
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Bug 1403215 hasn't actually made it to m-c yet.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: --- → Firefox 58
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Blocks: 1394533
Hi Ed, could you request an uplift to beta 57?
Flags: needinfo?(edilee)
Does this need to be uplifted?
Flags: needinfo?(edilee)
(In reply to Ed Lee :Mardak from comment #6)
> Does this need to be uplifted?

Oops, I didn't notice there's no patch for this bug.
According to comment 3, this will be handled in bug 1403215.
So ignore my question.  Thanks, Ed.
I have reproduced this bug with Nightly 57.0a1 (2017-09-22) in Ubuntu 16.04 LTS!

This bug's fix is verified with latest Beta and latest Nightly!

Build ID   : 20171005195903
User Agent : Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0

Build ID   : 20171008131700
User Agent : Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
QA Whiteboard: [bugday-20171004]
I have reproduced this bug with Nightly 57.0a1 (2017-09-21) on Windows 10 , 64 Bit ! 
 
This bug's fix is Verified with latest Beta and latest Nightly !

Build   ID    20171005195903
User Agent    Mozilla/5.0 (Windows NT 10.0; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0

Build   ID    20171008131700
User Agent    Mozilla/5.0 (Windows NT 10.0; WOW64; rv:58.0) Gecko/20100101 Firefox/58.0

[bugday-20171004]
As per comment 9 and comment 10, I am marking this bug as Verified Fixed!
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.