Closed Bug 1402622 Opened 2 years ago Closed 2 years ago

Firefox Quantum gets cut off on the About dialog

Categories

(Firefox :: Theme, defect, P5)

defect

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox57 --- verified
firefox58 --- verified

People

(Reporter: RyanVM, Assigned: shorlander)

References

Details

Attachments

(7 files, 1 obsolete file)

Attached image Firefox Quantun
I run local builds with official branding and noticed today that Quantum gets cut off. I assume we want to fix this :)
Flags: needinfo?(shorlander)
I'm on a hi-dpi system too in case that's important.
Blocks: 1398319
Flags: needinfo?(dao+bmo)
Group: mozilla-employee-confidential
Attached image Linux screenshot
Can't reproduce on Linux...
Flags: needinfo?(dao+bmo)
Also works on macOS. Will see if I can reproduce on Windows.
Flags: needinfo?(shorlander)
Attached image Beta 57 - Windows 10
Here is what I get on today's beta on Windows 10.
I see the same on 57 Beta builds. As I mentioned on IRC yesterday, I suspect this is a quirk of building trunk with official branding. I noticed when comparing the dialogs side by side that the Beta one is a bit wider and not quite as tall. Anyway, certainly not nearly as important now since this is extreme edge case :)
Priority: -- → P5
I'm seeing this on two different installs -- one on a machine with HiDpi, and one on a machine without. Both are Macs. This are official builds, downloaded via the Beta distribution channel. Let me know if there's anything I can do to help isolate the issue.
Adam said on IRC he was using OSX 10.10. I haven't been able to reproduce on Retina MBP w/ 10.12 on it nor on two other Win10 laptops in my possession, but it appears we're not entirely out of the woods here yet either. Stephen, any thoughts on how to proceed?
Flags: needinfo?(shorlander)
I can't reproduce this anywhere. I am not sure what is causing it.

Changing the dimensions of the wordmark.svg might fix it.
Flags: needinfo?(shorlander)
Attached patch update-quantum-wordmark.patch (obsolete) — Splinter Review
This makes the wordmark a little smaller. Should hopefully prevent it from getting cropped.
Attachment #8912410 - Flags: review?(dao+bmo)
Comment on attachment 8912410 [details] [diff] [review]
update-quantum-wordmark.patch

>+<svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" width="300" height="38" viewBox="0 0 300 38">
>+  <g fill="#fff">

nits:
- remove data-name="Layer 1"
- set fill on the svg node and remove <g>
Attachment #8912410 - Flags: review?(dao+bmo) → review+
Assignee: nobody → shorlander
Attachment #8912665 - Flags: review?(dao+bmo) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9ab11fa73cc4
Reduce size of Quantum wordmark to prevent it from possibly getting cropped. r=dao
Comment on attachment 8912665 [details] [diff] [review]
update-quantum-wordmark.patch

Approval Request Comment
[Feature/Bug causing the regression]: bug 1398319
[User impact if declined]: about dialog wordmark might be cropped, exact conditions are unclear
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]: no, Ryan or Adam should just verify this
[List of other uplifts needed for the feature/fix]: /
[Is the change risky?]: no
[Why is the change risky/not risky?]: only makes the svg a bit smaller
[String changes made/needed]: /
Attachment #8912665 - Flags: approval-mozilla-beta?
Comment on attachment 8912665 [details] [diff] [review]
update-quantum-wordmark.patch

Seems like a good idea to fix this promptly, Beta57+
Attachment #8912665 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
This appears to have fixed the problem on the systems I have access to.

Verified with `mozregression --repo mozilla-beta --launch c4367bba6dbd`
https://hg.mozilla.org/mozilla-central/rev/9ab11fa73cc4
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Looking good here now too. Thanks!
Status: RESOLVED → VERIFIED
Since this is a very user-facing area, I think it's best to be safe and double-check this on Beta 57.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.