Closed Bug 1402731 Opened 3 years ago Closed 3 years ago

Crash in mozilla::dom::workers::WorkerPrivateParent<T>::DispatchPrivate

Categories

(Core :: DOM: Core & HTML, defect)

55 Branch
Unspecified
All
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1381748
Tracking Status
firefox55 --- affected

People

(Reporter: yoasif, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-7ea8a3d1-d924-400a-bec9-6363a0170924.
=============================================================

This seems to have reappeared in Firefox 55. Previously fixed in #1334165. 

16078 crashes in the last 7 days.

Windows 10	6898
Windows 7	6670
Windows 8.1	1687
Windows 8	276
Linux	187
OS X 10.12	139
OS X 10.11	112
See Also: → 1334165
Crash volume became very significant in 55.0.3. No report on 56 or 57 so far ...

Could either of you take a look, please?
Flags: needinfo?(bkelly)
Flags: needinfo?(amarchesini)
It looks like the fetch consumption stuff Andrea might have already been working to fix on beta/nightly.
Flags: needinfo?(bkelly)
Yes, I would say that it has been fixed by bug 1381748.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(amarchesini)
Resolution: --- → DUPLICATE
Duplicate of bug: 1381748
Crash Signature: [@ mozilla::dom::workers::WorkerPrivateParent<T>::DispatchPrivate] → [@ mozilla::dom::workers::WorkerPrivateParent<T>::DispatchPrivate] [@ RtlAcquireSRWLockExclusive | mozilla::detail::MutexImpl::lock | mozilla::dom::workers::WorkerPrivateParent<T>::DispatchPrivate]
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.