Unlocalised Date/Time format returned

RESOLVED DUPLICATE of bug 153586

Status

()

Core
Internationalization
P4
normal
RESOLVED DUPLICATE of bug 153586
16 years ago
10 years ago

People

(Reporter: Rose Smyth, Assigned: smontagu)

Tracking

({intl})

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
This bug was logged against German MachV Beta.
http://bugscape.netscape.com/show_bug.cgi?id=14339
This is on German Windows 2000 with German regional settings.
*** change your PC's system date to 2001 *** 

- start German Mach 5 (2002-04-22)
- open  http://www.compuserve.de/pin
- warning message appears: "Server-Zertifikat noch nicht gültig" (not valid yet)
"Bitte überprüfen Sie, ob Zeit und Datum (derzeit Wednesday, November 28, 2001 
13:45:07) auf Ihrem Computer korrekt eingestellt sind."

***Result:
Date is not localized.

***Expected:
Date should be localized 
(with the correct date format: in this case: Mittwoch, 28. November 2001)
(Reporter)

Updated

16 years ago
Keywords: intl, l12y
Summary: Unlocalised Date/Time format → Unlocalised Date/Time format returned

Comment 1

16 years ago
Reassigning
Assignee: ssaux → kairo
Component: Client Library → German-Austria/de-AT
Product: PSM → Browser Localizations
QA Contact: junruh → Sebastian
Version: 2.1 → unspecified

Comment 2

16 years ago
This is definately no Bug in Mozilla German component, as MachV is surely not
Mozilla German. It looks like a Mozilla L12y issue though, reassigning to
Localization component.

Comment 3

16 years ago
This is definately no Bug in Mozilla German component, as MachV is surely not
Mozilla German. It looks like a Mozilla L12y issue though, reassigning to
Localization component.
Assignee: kairo → rchen
Component: German-Austria/de-AT → Localization
Product: Browser Localizations → Browser
QA Contact: Sebastian → ruixu
Version: unspecified → other

Updated

16 years ago
QA Contact: ruixu → kasumi

Comment 4

16 years ago
The date could be generated by the page at the server side.
The component should be internationalization not localization.
>*** change your PC's system date to 2001 *** 
why you do so ?

Assignee: rchen → yokoyama
Component: Localization → Internationalization
QA Contact: kasumi → ruixu

Updated

16 years ago
Keywords: l12y
QA Contact: ruixu → kasumi
(Reporter)

Comment 5

16 years ago
The date on the PC was changed in order to generate the error message, that the
certificate is not valid and requesting the user to check their system date.
The message is from pippki.properties:
serverCertExpiredMsg2=You should check to make sure that your computer's time
(currently set to %S) is correct.

Comment 6

16 years ago
cc tao

Comment 7

16 years ago
assign to l10n
Assignee: yokoyama → rchen
Component: Internationalization → Localization
QA Contact: kasumi → ruixu

Comment 8

16 years ago
taking it back. not l10n issue from ftang's comment.
Assignee: rchen → yokoyama
Component: Localization → Internationalization

Updated

16 years ago
QA Contact: ruixu → kasumi

Comment 9

16 years ago
It looks like currDate.toLocaleString() is returning non-German Date.
http://lxr.mozilla.org/seamonkey/source/security/manager/pki/resources/content/serverCertExpired.js#45

according to the JavaScript help, it should return the default date string:
-----------------------------------------
METHOD:  Date::toLocaleString
object.toLocaleString( )

This method uses the relevant locale's date conventions when converting a date
to a string. This is done by using the default date format of the user's
operating system.
--------------------------------------
kasume: can you reproduce this bug?

Comment 10

16 years ago
Yokoyama-san:
Do you have compuserve login ID?
test URL  http://www.compuserve.de/pin is compuserver login page.
I can't obtain that warning page unless I type userID/Password.   

Comment 11

16 years ago
Yes. I can. I will attach the screen capture.
This test is held on 2002-07-17-08-1.0 + language pack JA onWin XP pro.JA SP1 beta.
My date/time format setting is 2001/07/19 H:mm:ss for short.
2001nen07tsuki19hi(in Kanji)H:mm:ss for long.    

Comment 12

16 years ago
Created attachment 91987 [details]
for comment #13

Comment 13

16 years ago
Another case:Please refer attachment
Time/Date setting: Please refer attachment

Comment 14

16 years ago
corrextion attachment comment #13 -> comment #12

Comment 15

16 years ago
Created attachment 91990 [details]
for comment #13

Comment 16

16 years ago
Created attachment 91993 [details]
Date setting

Comment 17

16 years ago
Created attachment 91994 [details]
Time setting

Comment 18

16 years ago
I can reproduce.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 19

15 years ago
estimate effortws 1 day
Priority: -- → P4

Comment 20

15 years ago
estimate 1 day of work
Assignee: yokoyama → ftang

Comment 21

15 years ago
assign
Status: NEW → ASSIGNED

Updated

15 years ago
QA Contact: kasumi → marina

Comment 22

13 years ago
what a hack. I have not touch mozilla code for 2 years. I didn't read these bugs
for 2 years. And they are still there. Just close them as won't fix to clean up.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX

Comment 23

13 years ago
Mass Bug Re-Open of bugs Frank Tang Closed with no good reason. Spam is his
fault not my own
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 24

13 years ago
Mass Re-assinging Frank Tangs old bugs that he closed won't fix and had to be
re-open. Spam is his fault not my own
Assignee: ftang → nobody
Status: REOPENED → NEW
Filter on "Nobody_NScomTLD_20080620"
Assignee: nobody → smontagu
QA Contact: marina → i18n
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 153586
You need to log in before you can comment on or make changes to this bug.