View Source Does not show line numbers or allow jump to line number

VERIFIED DUPLICATE of bug 15364

Status

Core Graveyard
View Source
--
enhancement
VERIFIED DUPLICATE of bug 15364
17 years ago
8 years ago

People

(Reporter: nate parsons, Assigned: Doron Rosenberg (IBM))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc1) Gecko/20020417

The View Source window for Mozilla lacks a critical feature for webdevelopers. 
When viewing the source of a page it does not print the line number of each
line, nor does it allow the user to jump to a specific line.  This is very
unfortunate for server side script developers as the line number of the source
does not coorispond to anything meaningful in our script.  If the view source
feature simply had the line numbers in a left hand gutter or allowed the user to
jump to a specific line number this feature would be MUCH more useful.  The
javascript console is a great enhancement to development, but the lack of line
numbers in the view source makes it a frustrating experience to use in complex
situations.  

Reproducible: Always
Steps to Reproduce:
1.load web page
2.hit ctrl-U
3.

Actual Results:  source was opened in mozilla view source program without line
numbers.

Expected Results:  Should have allowed user the option to define a seperate
application to view page source with or provided line numbers and jump to line
number functionality in program.

This is a simple feature that would make people realize how thoughtful and
wonderful the mozilla project is.  It really should be strongly considered as a
high priority with the release of 1.0 coming up.  I'm sorry I didn't mention it
sooner but RC1 was the first mozilla build I've used enough to get frustrated
with this lack. =)  I'd love to hear back from you guys on this...

Comment 1

17 years ago
Quoting from the other duplicate from today:

Bug 15364 -- Add line numbers to View Source
Bug 79612 -- [RFE] Source file links in JS Console should jump to line number of
             problem
Bug 104383 -- Ability to go to specific line number in View Source window

*** This bug has been marked as a duplicate of 15364 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
vrfy
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

8 years ago
Component: View Source → View Source
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.