Correct Fragment as specified by Fragment Identifier in URI not always displayed correctly

VERIFIED DUPLICATE of bug 60307

Status

()

defect
VERIFIED DUPLICATE of bug 60307
17 years ago
17 years ago

People

(Reporter: kristoff_batizy, Assigned: attinasi)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    2002041711

At http://www.batizy.com/moz-bug/ there is an anomaly where the proper position
in the document is not always navigated to when the URI contains a fragment
identifier.
The links on the left of the page for "Cool Cars","SRT-4","M-80", and "Viper
GTS-R(via regular link)" work correctly.

But the link on the left of the page for " Viper GTS-R (via dispatcher)" does
not work correctly. The correct URI is shown, but not the correct fragment. It's
position is off. 

The difference is that the links which work are direct HREFs, whereas the one
that does not work goes through a dispatcher
(http://www.batizy.com/moz-bug/helpdispatcher.html) This was originally noticed
in a more complex scenario using servlets and jsps, but I have re-created a
simpler version here that just uses static html.


Reproducible: Always
Steps to Reproduce:
Create a scenario similar to http://www.batizy.com/moz-bug/ and as described above.

Actual Results:  The correct URI fragment is not shown.

Expected Results:  The correct URI fragment, as identified by the URI and
fragment identifier in the dispatcher, should be shown. It is actually off. The
larger the document and the more images in the document, the more off it becomes.


The helpdispatcher.html that I am using in this test is:
http://www.batizy.com/moz-bug/helpdispatcher.html
and contains:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>

<head>
  <title>Help Dispatcher</title>
  <meta http-equiv="refresh" content="1; url=main.html#topic-04">
</head>

<body>
</body>
</html>
worksforme....  Are your images loading slowly?  If so, this is bug 60307...
Reporter

Comment 2

17 years ago
Looks like it is the same as 126882 which has been marked as a duplicate of 60307.

*** This bug has been marked as a duplicate of 60307 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Changing QA Contact
QA Contact: petersen → moied

Comment 4

17 years ago
verified dup -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.