Closed Bug 1403596 Opened 2 years ago Closed 2 years ago

Buttons misaligned between URL bar and tabs tray

Categories

(Firefox for Android :: Theme and Visual Design, defect)

57 Branch
All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
fennec + ---
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- verified
firefox58 --- verified

People

(Reporter: david+bugzilla, Assigned: jwu)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [FNC][SPT58.2][MVP])

Attachments

(3 files)

Attached image alignment.png
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170925150345

Steps to reproduce:

Update to the latest Firefox for Android Beta and use the "tabs drawer"


Actual results:

The menu icon wanders and the "new tab"-button is no longer at the same spot as the "show tabs"-button (see alignment.png)


Expected results:

The theme should be consistent, without jumping buttons.
The background color also changes slightly if you test it with private tabs. Not sure if that's intended.
(In reply to David from comment #0)
> Actual results:
> 
> The menu icon wanders and the "new tab"-button is no longer at the same spot
> as the "show tabs"-button (see alignment.png)

The spec (https://drive.google.com/file/d/0B-9PIePlQZRldk9INm9TUXBkcWs/view) did say on page 11 (page 14 in the PDF) about the tabs tray that "The icons' position reference on icons on the tool bar".

It's probable that the button padding on the URL has since then been reduced in order to leave more room for the URL display itself or something like that (probably in https://hg.mozilla.org/mozilla-central/rev/993fc12edaa7#l3.13, which reduced the margin from 48 to 42 dp). If so, the same change should probably be made for the tabs tray itself, although so far at least for me the misalignment luckily isn't large enough to have broken my "tap twice to open a new tab" flow.
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Component: General → Theme and Visual Design
Ever confirmed: true
OS: Unspecified → Android
Hardware: Unspecified → All
Summary: Buttons/icons misaligned in new white theme → Buttons misaligned between URL bar and tabs tray
Assignee: nobody → topwu.tw
Attached image alignment comparison
With this patch, the menu buttons should be aligned between URL bar and tabs tray, the attachment is a screenshot for comparison.
Comment on attachment 8915431 [details]
Bug 1403596 - Adjust menu buttons position on tabs panel.

https://reviewboard.mozilla.org/r/186626/#review191704
Attachment #8915431 - Flags: review?(cnevinchen) → review+
Pushed by topwu.tw@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/3bc910534805
Adjust menu buttons position on tabs panel. r=nechen
https://hg.mozilla.org/mozilla-central/rev/3bc910534805
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Comment on attachment 8915431 [details]
Bug 1403596 - Adjust menu buttons position on tabs panel.

Approval Request Comment
[Feature/Bug causing the regression]:
Adjust menu button layout on tabs tray.

[User impact if declined]:
The space between menu buttons on toolbar and tabs tray is not consistent. This is Photon related UI bug.

[Is this code covered by automated tests?]:
No

[Has the fix been verified in Nightly?]:
Not yet

[Needs manual test from QE? If yes, steps to reproduce]: 
Yes. Please check the menu button layout on tabs tray is identical to screenshot in attachment 8915433 [details].

[List of other uplifts needed for the feature/fix]:
None

[Is the change risky?]:
No

[Why is the change risky/not risky?]:
This patch only adjust UI layout.

[String changes made/needed]:
No
Attachment #8915431 - Flags: approval-mozilla-beta?
Comment on attachment 8915431 [details]
Bug 1403596 - Adjust menu buttons position on tabs panel.

Recent regression, beta57+
Attachment #8915431 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified as fixed in build 58.0a1 (2017-10-11);
Device: Sony Xperia Z5 Premium (Android 6.0.1).
Whiteboard: [FNC][SPT58.2][MVP]
Verified as fixed in build 57.0b9;
Device: Samsung Galaxy Tab 3 (Android 7.0).
Status: RESOLVED → VERIFIED
tracking-fennec: ? → +
You need to log in before you can comment on or make changes to this bug.