Closed Bug 1403854 Opened 5 years ago Closed 5 years ago

Some Google fonts are not rendered by Firefox

Categories

(Core :: Graphics: Text, defect)

55 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1331797
Tracking Status
firefox-esr52 --- affected
firefox55 --- affected
firefox56 --- affected
firefox57 --- affected
firefox58 --- affected

People

(Reporter: alban, Unassigned)

Details

(Keywords: testcase)

Attachments

(2 files)

Attached image typos.jpg
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36

Steps to reproduce:

Use the following simple test case :

<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="UTF-8">
    <title>Typo test</title>
</head>
<body>

<style>
    @import url('https://fonts.googleapis.com/css?family=Archivo+Narrow');
    @import url('https://fonts.googleapis.com/css?family=Germania+One');
    .archivo{font-family:'Archivo Narrow', sans-serif;}
    .germania{font-family: 'Germania One', cursive;}
</style>
<span class="archivo">This sentence should show 'Archivo Narrow', sans-serif</span><br />
<span class="germania">This sentence should show 'Germania One', cursive</span>
</body>
</html>


Actual results:

See attached screenshot for result.

The font "Archivo" does not render properly in Firefox Nightly (nor in firefox current stable builds), while it renders properly in competiting browsers. Another Google font, "Germania", does render properly. This problem is always reproducible and occurs with several species of Google fonts. 

As we know Google fonts is now the most employed vector for displaying typography, it is important to solve this issue.


Expected results:

The font archivo should show up properly instead of being degraded to serif
Component: Untriaged → Graphics: Text
Product: Firefox → Core
Attached file testcase
Confirmed on Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0 ID:20170927100120.

Attaching the html provided as a test case
This is a regression as it works correctly in 55.0.2

The Browser console gives this output:
downloadable font: Layout: DFLT script doesn't satisfy the spec. DefaultLangSys is NULL (font-family: "Archivo Narrow" style:normal weight:normal stretch:normal src index:2) source: https://fonts.gstatic.com/s/archivonarrow/v7/DsLzC9scoPnrGiwYYMQXpkU-p1xzoRgkupcXIqgYFBc.woff2  unknown:10:11
downloadable font: Layout: Failed to parse script table 0 (font-family: "Archivo Narrow" style:normal weight:normal stretch:normal src index:2) source: https://fonts.gstatic.com/s/archivonarrow/v7/DsLzC9scoPnrGiwYYMQXpkU-p1xzoRgkupcXIqgYFBc.woff2  unknown:10:11
downloadable font: GSUB: Failed to parse script list table (font-family: "Archivo Narrow" style:normal weight:normal stretch:normal src index:2) source: https://fonts.gstatic.com/s/archivonarrow/v7/DsLzC9scoPnrGiwYYMQXpkU-p1xzoRgkupcXIqgYFBc.woff2  unknown:10:11
downloadable font: GSUB: Failed to parse table (font-family: "Archivo Narrow" style:normal weight:normal stretch:normal src index:2) source: https://fonts.gstatic.com/s/archivonarrow/v7/DsLzC9scoPnrGiwYYMQXpkU-p1xzoRgkupcXIqgYFBc.woff2  unknown:10:11
downloadable font: rejected by sanitizer (font-family: "Archivo Narrow" style:normal weight:normal stretch:normal src index:2) source: https://fonts.gstatic.com/s/archivonarrow/v7/DsLzC9scoPnrGiwYYMQXpkU-p1xzoRgkupcXIqgYFBc.woff2
Status: UNCONFIRMED → NEW
Ever confirmed: true
Removing the regression keyword, it works correctly on 55 for me because I tested with the Firefox provided by the distro which is probably compiled with different options.

Using mozregression, I found that this was an intended change in Fx44: https://bugzilla.mozilla.org/show_bug.cgi?id=1193050#c35

That said, the message sent to https://lists.w3.org/Archives/Public/public-webfonts-wg/2016Jan/0000.html seemed to indicate that Chrome would do the same at some point, I don't know if they did but fond a workaround to display buggy fonts and hence have a better fix than we do or if they didn't.

:jfkthame should we close this bug?
This is the same issue as described in bug 1331797 (and other reports).

I'm told Google Fonts should be deploying a fix quite soon now.

(Meanwhile, note that users on Beta and Release builds are unaffected because we relax the validation checks there.)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.