Prints image on page twice, first time image is distorted

RESOLVED DUPLICATE of bug 146799

Status

()

RESOLVED DUPLICATE of bug 146799
17 years ago
16 years ago

People

(Reporter: garrettk, Assigned: rods)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

The page at http://www.nathan.com/projects/current/communications.html contains
an image that, if printed on an HPDJ970 with no scaling, falls on the page
break.  When the page is printed, the image is first printed with significant
vertical compression (a 3-inch high image measures about 1" vertically), and
then is printed a second time, correctly, on the next page.  The print preview,
however, displays correctly.  The resultant document is usable, just not what's
displayed on the screen.

Reproducible: Always
Steps to Reproduce:
1.  Open the page
2.  Select File | Print

Actual Results:  Printed two copies of the image, the first one with significant
distortion (vertical compression).

Expected Results:  Should only print the image once.  Either print part of image
on first page and the rest on the next page (that's what's shown in the print
preview), or print the whole thing on the next page.

Comment 1

17 years ago
using 4/26 build on Win 98 I see part of image on first page and the rest on the
next page.

try again with a more recent build.

Comment 2

17 years ago
I see this same problem on Windows XP with Build ID: 2002052306. The print
preview is as reported by garettk. The preview shows images split across pages
but the actual printout contains two of every image that spans pages. Each image
is vertically compressed to some extent which makes them unreadable in most cases.

Try the following link:

http://www.eedesign.com/printableArticle?doc_id=OEG20020307S0039

Also, it would be nice to have user preferences to set whether or not images get
split across pages or forced to be on one page. 

I've printed this exact same document with Explorer with the exact same printer
and printer settings and do not get the compression problem. But then Explorer
seems to not split images across pages anyway (don't know if I have control over
that). Scale to fit is not set for the printer.

I had also printer part2 of the same article at work using release candidate 2
on a linux box and it did not have this problem.

If you need any other or more specific info to confirm this let me know.....



*** This bug has been marked as a duplicate of 146799 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.