Closed Bug 1403976 Opened 4 years ago Closed 4 years ago

webrendest: linear-gradient as bg image gets not cut by border-radius

Categories

(Core :: Graphics: WebRender, defect, P1)

x86_64
Linux
defect

Tracking

()

VERIFIED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- fixed

People

(Reporter: jan, Assigned: gw)

References

()

Details

(Keywords: nightly-community, Whiteboard: [wr-mvp])

Attachments

(2 files)

Attached file wr-testcase.html
Nightly 58 x64 20170928100123 de_DE @ Debian Testing (KDE / Radeon RX480)
gpu-process + layers force accel + webrender (layersfree) + webrendest

The "Notify me" button on https://www.mozilla.org/en-US/firefox/quantum/ does not have rounded corners when webrendest is enabled.

If I set a real image as background in my testcase, I can't reproduce this, so this might be only related to linear-gradient.
This seems to have to do with the fact that the gradient is repeated and that it starts at 17%. Adding background-repeat: no-repeat and making it start at 0% fixes it. Probably a bug in webrender itself.

(It's repeated because there is a border, and background-origin is padding-box while background-clip is border-box, so it gets repeated slightly under the border.)
Priority: -- → P2
Whiteboard: [wr-mvp]
This is fixed in webrender revision 9ba91c397de9c8fef3b788e6f9af070eeac72a5a and will be picked up by the next webrender update (bug 1405399).
Depends on: 1405399
See comment 3 + comment 4.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Priority: P2 → P1
Verified fixed in Nightly 58 x64 20171005100211 de_DE @ Debian Testing.
gpu process + layers force acccel + webrender + webrendest
attachment 8913254 [details] is now looking like the upper half of attachment 8913256 [details] when webrendest is enabled.
Status: RESOLVED → VERIFIED
Assignee: nobody → gwatson
You need to log in before you can comment on or make changes to this bug.