consider if Range header should be exposed on FetchEvent.request

RESOLVED DUPLICATE of bug 1465074

Status

()

enhancement
P3
normal
RESOLVED DUPLICATE of bug 1465074
2 years ago
11 months ago

People

(Reporter: bkelly, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Currently we never expose the Range header on FetchEvent.request.  This is because its added down in the http cache and network path here:

https://searchfox.org/mozilla-central/source/netwerk/protocol/http/nsHttpChannel.cpp#4208

Its unclear if this should ever be exposed to script in FetchEvent.request.  I filed a spec issue about that here:

https://github.com/w3c/ServiceWorker/issues/1201
Priority: -- → P3
(Reporter)

Comment 1

11 months ago
This is being spec'd.  See bug 1465074.
No longer blocks: ServiceWorkers-compat
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1465074
You need to log in before you can comment on or make changes to this bug.