Closed Bug 1404055 Opened 2 years ago Closed 2 years ago

Remove extension if there was an error during installation

Categories

(DevTools :: about:debugging, defect)

55 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1330732

People

(Reporter: gabybosetti, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170816204344

Steps to reproduce:

I updated my temporary extension (from about:debugging) after some changes in the code. There was a problem with the installation, but I was not informed and the extension looked as properly installed. What really happened is that the previous version of the tool was kept. I removed the extension and installed it again, so I could see that there was some error in my new version of the extension. The problem is that as there is no error message when updating, you can not guess that your new version is not currently installed. I think it should be great if there is a message or, at least, the old version is removed. Thanks in advance.


Actual results:

I was not prevented that I was using an old version of the extension


Expected results:

An error message should be presented to the user, or the old version uninstalled.
Component: WebExtensions: Developer Tools → Developer Tools: about:debugging
Product: Toolkit → Firefox
Status: UNCONFIRMED → NEW
Ever confirmed: true
Since Firefox 56 (bug 1330732) you should get a message that the extension failed to install. It looks like you were on 55 when you tried this so updating to the latest release version should fix it for you.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1330732
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.