Closed Bug 1404075 Opened 2 years ago Closed 2 years ago

Search results appearing on new profile, no add-ons installed, cleared browsing history

Categories

(Firefox :: Address Bar, defect)

57 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1341591

People

(Reporter: jed-development, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: ux-affordance)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20170927100120

Steps to reproduce:

Created a new profile, turned off 'Show search suggestions in address bar results' and cleared everything from history (just to make sure there was absolutely nothing in history). Typed a letter between a-z in the titlebar (for example 'm').


Actual results:

Web addresses appeared of sites I knew and didn't know. I hadn't heard of over 50% of them. I tried completely unticking Provide search suggestions, and unticked Browsing history, Bookmarks and Open tabs suggestions for the address bar and nothing appears. As soon as any of the 3 options are ticked though, doesn't matter which, the random list of URLs appears.


Expected results:

As it's a completely fresh profile I would expect nothing to show up whatsoever, even with all the settings ticked. Note: had to select 57 branch as there isn't a 58 branch option, though this applies to the 58 branch.
It is a feature, see bug 1340663.
Blocks: 1340663
Has STR: --- → yes
Component: Untriaged → Address Bar
Keywords: ux-affordance
(In reply to YF (Yang) from comment #1)
> It is a feature, see bug 1340663.

It feels like it's localising wrong. I would expect it to show the UK versions of sites, considering I installed the UK version. For example, google.com should be google.co.uk, and Baidu, QQ, Sohu etc. are not even English sites, let alone UK English.
it's a nightly only feature exactly because it's not localized properly yet.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1341591
(In reply to Marco Bonardo [::mak] from comment #3)
> it's a nightly only feature exactly because it's not localized properly yet.

Will there be an option to switch this on or off? It's not a feature I particularly like or want. Maybe an option in the installer or in about:preferences would be welcome.
it disables by itself after the profile is 14 days old. So most users won't ever see it. it's just to help new users browsing to the most common sites.
(In reply to Marco Bonardo [::mak] from comment #5)
> it disables by itself after the profile is 14 days old. So most users won't
> ever see it. it's just to help new users browsing to the most common sites.

What about disabling it early if Firefox Sync is used? I've found that you can't remove the suggestions with the delete key, they just come back, and they get prioritised over my own preferred URL autofilling meaning when I type for example 'a', usually that would autocomplete as amazon.co.uk and it would take me there, but instead that autofilling process either doesn't work and I end up at a Google search or it takes me to the suggested site (amazon.com) as that usually autofills first.
You need to log in before you can comment on or make changes to this bug.