Closed Bug 1404179 Opened 3 years ago Closed 3 years ago

Intermittent css-ruby/line-breaking-1.html == css-ruby/line-breaking-1-ref.html | image comparison, max difference: 255, number of differing pixels: 252

Categories

(Core :: Layout, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: xidorn)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed:product])

Attachments

(1 file)

Blocks: 1401420
Xidorn, looks like this started with your push. Can you please take a look?
Flags: needinfo?(xidorn+moz)
I'll look into this tomorrow.
Assignee: nobody → xidorn+moz
Flags: needinfo?(xidorn+moz)
Thanks Xidorn. This is currently one of the most frequent failures.
Whiteboard: [stockwell needswork]
Duplicate of this bug: 1405084
Duplicate of this bug: 1405134
:xidorn, any progress here, 100+ failures/day, this is on the border of perma fail- I will disable this tomorrow if I don't hear otherwise.
Flags: needinfo?(xidorn+moz)
It's not on the border, it's permaorange on Android debug and has been since it landed.
Sorry -- this is just pending my review response, I think.  I intend to get to the review in the next hour or so. (I glanced at it earlier and it looked not-100%-trivial, which is why I haven't gotten to it already.)

(Having said that, I suspect it should be fine to disable the test in the meantime, if it's really permafail and causing trouble.)
The patch basically just reverts MoveOverflowToChildList, and duplicates most of its code into a new method MoveInlineOverflowToChildList.
Flags: needinfo?(xidorn+moz)
Comment on attachment 8914610 [details]
Bug 1404179 - Prepend rather than append frames from overflow list of prev-in-flow for ruby frames.

https://reviewboard.mozilla.org/r/185944/#review191236

r=me

::: layout/generic/nsContainerFrame.cpp:1558
(Diff revision 1)
> +      // We may need to reparent floats from prev-in-flow to our line
> +      // container if there the container has prev continuation.

There's an extraneous word in here somewhere ("if there the container")

I think you want to drop "there"?
Attachment #8914610 - Flags: review?(dholbert) → review+
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1d032adb1d58
Prepend rather than append frames from overflow list of prev-in-flow for ruby frames. r=dholbert
https://hg.mozilla.org/mozilla-central/rev/1d032adb1d58
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Whiteboard: [stockwell disable-recommended] → [stockwell fixed:product]
You need to log in before you can comment on or make changes to this bug.