The default bug view has changed. See this FAQ.

render MathML &prime; as a mathematical prime in contexts other than <msup>

RESOLVED DUPLICATE of bug 442637

Status

()

Core
MathML
--
enhancement
RESOLVED DUPLICATE of bug 442637
15 years ago
3 years ago

People

(Reporter: Torsten Bronger, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
&prime; should result in $'$, not in $\prime$.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

15 years ago
What do you mean? 'prime' is an overloaded character.
Do you have a testcase/screenshot of what you see?

Comment 2

15 years ago
I got the following explanation from the reporter:

> The MathML equivalent of LaTeX's $f'$ should be
> <math><mi>f</mi><mo>&prime;</mo></math>, but
> at the moment it's
> <math><msup><mi>f</mi><mo>&prime;</mo></msup></math>

It makes the bug report clear now. However, it isn't what the spec says. In
fact, the issue came up in the n.p.m.mathml newsgroup and the WG confirmed that
what Mozilla does is OK, though it was suggested that the other behavior could
be an enhancement. So this bug is a RFE.

Thread:
  http://groups.google.com/groups?hl=en&th=c907286f698426d8&rnum=1

Post from Robert Miner on the question:

> The question of marking up primes has come up several times with the
> Math WG, and everytime we have decided that in MathML, a prime should
> be attached as a superscript, eg
>
> <msup> <mi>f</mi> <mo>&prime;</mo>  </msup>
>
> The strongest argument is that this makes explicit to what the prime
> applies.


Updating the title to reflect the reality:
OLD title was: "MahML entity &prime; is wrongly interpreted"
NEW title is: "[RFE] render MathML &prime; as a mathematical prime in contexts
other than <msup>"

This could become a non-issue if generators become good enough.
Severity: normal → enhancement
OS: Linux → All
Hardware: PC → All
Summary: MahML entity &prime; is wrongly interpreted → [RFE] render MathML &prime; as a mathematical prime in contexts other than <msup>
What about when the prime is not an operator? e.g. is

   <msup> <mi>k</mi> <mo>&prime;</mo>  </msup>

...preferred over 

   <mi>k&prime;</mi>

...when trying to tell the difference between the variable /k/ and the related
but distinct variable /k'/ ?

Comment 4

15 years ago
That's is all quirky... "<mi>k&prime;</mi>" is always understooned means the
identifier k' (i.e., concat of a glyph for k and  a glyph for ' -- nothing
special expected). It is a very bad (MathML) markup for that purpose.

Anyway, I have little interest in seeing this bug fixed (I am tempted to mark
WONTFIX :-) As roc jotted in the other bug 121748, any quirk that is implemented
is likely to last forever, whereas generators can improve -- in which case, this
bug will become a non-issue.

Comment 5

15 years ago
s/That's is all quirky... "<mi>k&prime;</mi>" is always understooned means/
 /That's all quirky... "<mi>k&prime;</mi>" is always understood to mean/
Cool, so what should I use instead?

   <msup> <mi>k</mi> <mo>&prime;</mo>  </msup>

...?

   <msup> <mi>k</mi> <mi>&prime;</mi>  </msup>

...?

I'm kinda confused as to which is appropriate... In this context, the &prime; is
not an operator (which would imply differentiation), is it an identifier?

Comment 7

15 years ago
>  <msup> <mi>k</mi> <mo>&prime;</mo>  </msup>

yes this is the recommended markup. (if you were to 'hint' at
differentiation, you could do: <msup> <mo>k</mo> <mo>&prime;</mo> </msup>)

>  <msup> <mi>k</mi> <mi>&prime;</mi>  </msup>

In general, there isn't much that is done for '<mi>' (except the special-casing 
of non-stylable characters such as set R, or the italicized rendering in the 
case where the textual content consists of a single character). It is <mo> that 
is heavily overloaded (it is looked-up in the Operator Dictionary, and not only 
its content is significant, its position plays a role too -- whether it is 
prefix, infix, or suffix). So as a rule of thumb, '<mi>' is for things that are 
meant to be (italicized) identifiers while '<mo>' is for other things.
Alrighty. Thanks for the help!

Updated

13 years ago
Summary: [RFE] render MathML &prime; as a mathematical prime in contexts other than <msup> → render MathML &prime; as a mathematical prime in contexts other than <msup>
(Reporter)

Comment 9

12 years ago
My Firefox 1.0 now shows it as I wanted it to be.  Is this a "meta" bug or has
the policy changed?

Comment 10

10 years ago
I doubt if it's still working as Torsten wanted in Firefox 1.5.0.9.

There is inconsistency, both in Linux and WinXP, in the presentation
handling of &prime; and &Prime; (double prime).  The latter works
sanely as a postfix operator, while the former does not.  With
&prime;, however, there is an acceptable CSS workaround using
{vertical-align: super; font-size: 0.6em} for the <mo> container that
mostly -- but not always works.  See the XHTML page
http://www.albany.edu/~hammond/gellmu/primeaccents.xhtml
and the pictures
http://www.albany.edu/~hammond/gellmu/primeaccentsLinux.png and
http://www.albany.edu/~hammond/gellmu/primeaccentsWinXP.png.

I say the CSS snippet is an acceptable workaround
because for most purposes &prime is used by mathematical authors
as a superscripted postfix math accent (see Lamport's sample2e.tex).
For GELLMU I am reluctant to step on an author's usage by
superscripting it in the XML behind his back; touching it with CSS
is much less of an infringement.  On the other side, if I tell
the author he must superscript it, he will walk away.

I think the MathML spec at section 3.2.3.1 needs revision.

For Mozilla meanwhile please make &prime; behave like &Prime;.

Also I'm not happy with the response above to Ian Hixie; I think,
in fact, <mi>k&prime;</mi> is a sensible math token.  Otherwise
one is messing with cdata rather arbitrarily.  (The spec provides
for this inside <mo> but mostly not inside <mi>.)

For case distinctions attribute settings on the <mo> container should
be the best way to go -- with postfix superscripting the default --
when the content is one of prime, Prime, tprime, qprime.

Thanks.

Comment 11

10 years ago
In case the thrust of my comment a week ago is insufficiently
clear, I have written a slightly more elaborate version of the
first http reference in that comment.  It may be found at:
http://www.albany.edu/~hammond/gellmu/primeaccents2.xhtml

QA Contact: ian → mathml
Assignee: rbs → nobody
Depends on: 785956
The MathJax fonts render the prime at the right size, so that may explain why some people see this bug "fixed". For the STIX fonts, font-feature-settings can be used to select an alternative glyph. Compare

    <math style="font-family: STIX;">
      <msup><mi>x</mi><mo>&#x2032;</mo></msup>
      <msup><mi>x</mi><mo style="-moz-font-feature-settings: 'ss03'">&#x2032;</mo></msup>
    </math>

(however, this will be font specific)
No longer depends on: 785956
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 442637
You need to log in before you can comment on or make changes to this bug.