Closed Bug 1404601 Opened 2 years ago Closed 2 years ago

undeclared variable debug in nsSidebar.js

Categories

(SeaMonkey :: Sidebar, defect)

defect
Not set

Tracking

(seamonkey2.54 fixed, seamonkey2.55 fixed)

RESOLVED FIXED
seamonkey2.55
Tracking Status
seamonkey2.54 --- fixed
seamonkey2.55 --- fixed

People

(Reporter: frg, Assigned: frg)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1402671 +++

Variable debug is never declared in suite\common\src\nsSidebar.js

Error is almost identical to the one in bug 1402671.

> Timestamp: 9/30/2017, 12:55:28 PM
> Error: ReferenceError: assignment to undeclared variable debug
> Source File: file:///D:/seabuild/release/comm-beta-15/obj-x86_64-pc-mingw32/dist/bin/components/nsSidebar.js
> Line: 319
Comment on attachment 8913947 [details] [diff] [review]
1404601-debug.patch

[Approval Request Comment]
Regression caused by (bug #): Bug 1186409
User impact if declined: sidebar broken.
Testing completed (on m-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): none already broken.
String changes made by this patch: none

I am not sure it is the right bug number which broke it. Most code is now compiled in strict mode and this is what chauses this.
Attachment #8913947 - Flags: review?(iann_bugzilla)
Attachment #8913947 - Flags: approval-comm-beta?
Comment on attachment 8913947 [details] [diff] [review]
1404601-debug.patch

LGTM r/a=me
Attachment #8913947 - Flags: review?(iann_bugzilla)
Attachment #8913947 - Flags: review+
Attachment #8913947 - Flags: approval-comm-beta?
Attachment #8913947 - Flags: approval-comm-beta+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/36be15c040d5
Declare and rename debug function in nsSidebar.js. r=IanN
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.55
You need to log in before you can comment on or make changes to this bug.