Closed Bug 1404653 Opened 2 years ago Closed 2 years ago

Searching with StartPage custom search results in being brought to main page instead of actually searching

Categories

(Firefox :: Search, defect)

57 Branch
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 1435615
Tracking Status
firefox57 --- wontfix

People

(Reporter: asdfghrbljzmkd, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20170930001028

Steps to reproduce:

1. Open new tab
2. Type something in search/address bar


Actual results:

Sent to homepage.  Searching from the search/address bar a second time on the same tab works though.


Expected results:

Search should work the first time.

Note that I filed this bug for 57, as it first appeared in an update to Nightly during the 57 cycle, but the bug still affects the latest nightly.  Also note that this is a regression.

Settings used for the custom search:
https://screenshots.firefox.com/16vLZnl6QTrb81K4/us.startpage.com
Component: General → Search
Why?  It is a regression, a REALLY annoying one at that...
Please can you expand on your steps to repeat a bit more...

Have you previously set up startpage.com as your default search engine?

Which "homepage" do you get sent to one you type into the address bar for the first time?

Please can you also provide a screenshot including the Firefox interface (you can attach an image to the bug) for the case of where you type something but it loads the wrong item?
Flags: needinfo?(asdfghrbljzmkd)
Unfortunately without further information (at a minimum what I requested in comment 2) I don't think we are going to be help with this.

To me, it seems like an issue with startpage.com themselves, rather than Firefox. However I can't really tell without knowing more detailed steps to repeat and details of the setup.

If you're still having issues, please feel free to reopen and provide more details.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(asdfghrbljzmkd)
Resolution: --- → INCOMPLETE
Sorry for the late response, here are the full reproduction steps:

1. Create a new profile and go to https://www.startpage.com/do/preferences?language=english&language_ui=english&nj=0
2. Set all settings as shown in https://screenshots.firefox.com/16vLZnl6QTrb81K4/us.startpage.com
3. Click "Generate URL", then "Install custom plugin"
4. When FF prompts to add the search engine, check the box to make it the current search engine, then click "Add"
5. Go into the FF settings, and set FF to "Never remember history", then restart when prompted.
6. Open a new tab, type something the the address bar, and hit enter

You will then be brought to startpage.com rather than it searching with the specified search terms and settings set in step 2.

7. In the same tab, type a search in the address bar

You will then be taken to the actual search page with all of the specified search terms and settings set in step 2.

FF Nightly 58 from PPA
Xubuntu 17.10

Let me know if you need any more info.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Thank you for the steps. I've tried this on Mac and on Linux with the latest nightly and I can't reproduce it.

When I get to step 6, searching for things like "test", "garage" always brings up the startpage.com site *with* the required search terms.

The only way I can see that you'd get to just the startpage.com homepage or the settings page is if you searched for something like "start" - in that case, the history hit is being preferred to the domain (as show in the autocomplete drop-down), and it'll go to that page.

If you don't want that behaviour, you can go into Preferences -> Privacy & Security and turn off "Browsing History".


If that isn't the issue, then the only thing I can think of it is some weird bug with the site that you are hitting - and it is the startpage.com site that needs to fix it.

Please can you confirm if my thoughts above are what's happening.
Flags: needinfo?(asdfghrbljzmkd)
Did you remember to enable Private Browsing?  I think it may only happen in Private Browsing.

Also, because I have Private Browsing enabled, history is not the problem here.

If you still can't reproduce, I'll try testing some more.
Flags: needinfo?(asdfghrbljzmkd)
Were you able to reproduce?
Flags: needinfo?(asdfghrbljzmkd)
This is bug 1435615, which now has a patch.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago2 years ago
Flags: needinfo?(asdfghrbljzmkd)
Resolution: --- → DUPLICATE
Duplicate of bug: 1435615
Yes, seems to be the same issue (I recently independently discovered disabling the new tab page fixes the issue).
Status: RESOLVED → VERIFIED
Nice, thanks for verifying.
You need to log in before you can comment on or make changes to this bug.