Long font names with similar start in Preferences are indistinguishable

VERIFIED FIXED in Firefox 57

Status

()

P3
normal
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: alice0775, Assigned: rickychien)

Tracking

(Blocks: 1 bug, {regression})

57 Branch
Firefox 58
Unspecified
Windows 10
regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57+ verified, firefox58 verified)

Details

(Whiteboard: [photon-preference])

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
[Tracking Requested - why for this release]: The photon does not make sense. The preferences is completely unusable.

+++ This bug was initially created as a clone of Bug #1399963 +++

Build identifier:
Build ID 20170928180207
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Reproducible : always

Steps To Reproduce:
1. Open Preferences
2. Click select box of font list


Actual Results:
See screenshot

Font name is too short, indistinguishable.
Whiteboard: [photon-preferences] → [photon-preference][triage]

Updated

2 years ago
Summary: Font name in Preferences is Indistinguishable → Long font names with similar start in Preferences are indistinguishable
@Alice0775: Would you be able to take a screenshot of the same interface in Firefox 55?  I'd like to compare it to the new screenshot to understand the difference better.
(Reporter)

Comment 2

2 years ago
(Reporter)

Updated

2 years ago
Attachment #8914022 - Attachment description: screenshot → screenshot comparison beta(57.0b4) vs current(56.0.0)
I believe this is due to Photon visual refresh work from bug 1386514, but it doesn't relate to bug 1399963. In bug 1386514, the width of Preferences content area has been shrunk, causing the font family menulist to be shrunk as well. 

Per discussion with Helen (Preferences visual designer), we decided to remove the additional spacer between font-size and advanced button to increase the width of font family menulist.
Assignee: nobody → rchien
Blocks: 1357306
No longer blocks: 1375978
Status: NEW → ASSIGNED
Flags: qe-verify+
QA Contact: hani.yacoub
Comment on attachment 8914148 [details]
Bug 1404665 - Extend font family menulist by removing spacer in Preferences font & color section

https://reviewboard.mozilla.org/r/185468/#review190604

::: commit-message-41286:1
(Diff revision 1)
> +Bug 1404665 - Remove spacer in Preferecens font & color section r?jaws

This commit message needs to say *why* this is being removed. It's obvious from looking at the patch that it is being removed.

Also, spelling error, "Preferences" instead of "Preferecens".
Attachment #8914148 - Flags: review?(jaws) → review-
Comment on attachment 8914148 [details]
Bug 1404665 - Extend font family menulist by removing spacer in Preferences font & color section

https://reviewboard.mozilla.org/r/185468/#review190608

Since our timezones are far apart I don't want to make the patch wait another 12-24 hours so I'll grant r+ now but the commit message needs to be changed before landing.
Attachment #8914148 - Flags: review- → review+
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 9

2 years ago
Pushed by rchien@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dc3a6c6be8cc
Extend font family menulist by removing spacer in Preferences font & color section r=jaws
Comment on attachment 8914148 [details]
Bug 1404665 - Extend font family menulist by removing spacer in Preferences font & color section

Approval Request Comment
[Feature/Bug causing the regression]: bug 1386514
[User impact if declined]: minor, UI polish
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]: see description
[List of other uplifts needed for the feature/fix]: no
[Is the change risky?]: minor
[Why is the change risky/not risky?]: UI polish
[String changes made/needed]: none
Attachment #8914148 - Flags: approval-mozilla-beta?

Comment 11

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/dc3a6c6be8cc
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox58: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Priority: -- → P3
Whiteboard: [photon-preference][triage] → [photon-preference]
Comment on attachment 8914148 [details]
Bug 1404665 - Extend font family menulist by removing spacer in Preferences font & color section

Low risk, polish, makes sense, Beta57+
Attachment #8914148 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
tracking-firefox57: ? → +

Comment 13

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/d6424c273328
status-firefox57: affected → fixed
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171004100049

This issue has been verified on latest Firefox Nightly Build ID: 20171004100049 on Windows 8.1 x64, Mac OS 10.11 and Ubuntu 14.04 and it is not reproducible. Now, the long font names are visible.

This issue is still reproducible on Firefox Beta 57.0b5.
status-firefox58: fixed → verified

Comment 15

a year ago
Build ID: 20171009192146
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Verified as fixed on Firefox Beta 57.0b7 on Windows 10 x 64, Windows 7 x32, Mac OS X 10.12 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
status-firefox57: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.