Closed Bug 1404943 Opened 2 years ago Closed 2 years ago

Top Sites Edit button is not displayed until the Top Sites section is hovered

Categories

(Firefox :: New Tab Page, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox58 --- affected

People

(Reporter: cmuresan, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached image edit not visible.PNG
[Affected versions]:
- Firefox 58.0a1 Build ID 20171001220301

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Steps to reproduce]:
1. Start the browser and open a New Tab.
2. Observe the top right corner of the Top Sites area.
 
[Expected results]:
- The "Edit" button is displayed.

[Actual results]:
- The "Edit" button is not displayed.

[Regression window]:
Last good revision: 1bac4ad2bddb0517896ba78b407fb1301a55eb0f
First bad revision: a9af2009e4069ae9e4f26001f2e9fdde0bbcdc3e
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=1bac4ad2bddb0517896ba78b407fb1301a55eb0f&tochange=a9af2009e4069ae9e4f26001f2e9fdde0bbcdc3e

[Notes]:
- The button is only displayed when the Top Sites area is hovered.
- Attached a screen shot of the issue.
I'm not sure how bug 1396423 managed to introduce this behavior, but I ran mozregression a few times to be sure.
Gijs, can you take a look at this?
Flags: needinfo?(gijskruitbosch+bugs)
This is actually by design now: https://github.com/mozilla/activity-stream/pull/3628 added changes to show the edit button on hover now, with the info icon for Top Sites as well. We're tracking some behaviour bug in https://github.com/mozilla/activity-stream/issues/3631 to tune it though.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: --- → WONTFIX
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.