Closed Bug 1405248 Opened 2 years ago Closed 2 years ago

Add a test for openLink

Categories

(DevTools :: Console, enhancement, P3)

enhancement

Tracking

(firefox57 wontfix, firefox58 affected)

RESOLVED INVALID
Tracking Status
firefox57 --- wontfix
firefox58 --- affected

People

(Reporter: nchevobbe, Unassigned)

References

(Blocks 1 open bug)

Details

In the old console, browser_webconsole_clickable_urls.js tested that url were clickable. 
The URL-ification no happens in reps, and is well tested there. However, we don't have a test to make sure serviceContainer.openLink does the expected thing.
We should have a mochitest to make sure it works as intended (maybe log only one URL to the console and make sure we open a new tab is enough).
Priority: -- → P3
was already in the new frontend
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.