Closed Bug 1405357 Opened 4 years ago Closed 4 years ago

Intermittent TEST-UNEXPECTED-TIMEOUT | automation.py | application timed out after 330 seconds with no output

Categories

(Testing :: General, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1397201

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell unknown])

There have been 31 failures in the last 7 days, all of them on Windows 10 and it occurs only on opt & debug.

Here is an example of a recent log:
https://treeherder.mozilla.org/logviewer.html#?repo=mozilla-inbound&job_id=139876484&lineNumber=1760

And a snippet of the log where the timeout occurs:
14:35:51     INFO -  Running manifest: js\xpconnect\tests\chrome\chrome.ini
1747
14:35:51     INFO -  Z:\task_1509028429\build\tests\bin\pk12util.exe: PKCS12 IMPORT SUCCESSFUL
1748
14:35:51     INFO -  MochitestServer : launching [u'Z:\\task_1509028429\\build\\tests\\bin\\xpcshell.exe', '-g', 'Z:\\task_1509028429\\build\\application\\firefox', '-v', '170', '-f', 'Z:\\task_1509028429\\build\\tests\\bin\\components\\httpd.js', '-e', "const _PROFILE_PATH = 'c:\\\\users\\\\genericworker\\\\appdata\\\\local\\\\temp\\\\tmpj6mmw0.mozrunner'; const _SERVER_PORT = '8888'; const _SERVER_ADDR = '127.0.0.1'; const _TEST_PREFIX = undefined; const _DISPLAY_RESULTS = false;", '-f', 'Z:\\task_1509028429\\build\\tests\\mochitest\\server.js']
1749
14:35:51     INFO -  runtests.py | Server pid: 3300
1750
14:35:51     INFO -  runtests.py | Websocket server pid: 8868
1751
14:35:51     INFO -  runtests.py | SSL tunnel pid: 4492
1752
14:35:51     INFO -  runtests.py | Running with e10s: False
1753
14:35:51     INFO -  runtests.py | Running tests: start.
1754
14:35:51     INFO -  Application command: Z:\task_1509028429\build\application\firefox\firefox.exe -marionette -foreground -profile c:\users\genericworker\appdata\local\temp\tmpj6mmw0.mozrunner
1755
14:35:51     INFO -  runtests.py | Application pid: 5192
1756
14:35:51     INFO -  TEST-INFO | started process GECKO(5192)
1757
14:35:52     INFO -  GECKO(5192) | 1509028552412	Marionette	INFO	Enabled via --marionette
1758
14:35:53     INFO -  GECKO(5192) | 1509028553619	Marionette	INFO	Listening on port 2828
1759
14:41:23     INFO -  Buffered messages finished
1760
14:41:23  WARNING -  TEST-UNEXPECTED-TIMEOUT | automation.py | application timed out after 330 seconds with no output
1761
14:41:23     INFO -  0 ERROR Force-terminating active process(es).
1762
14:41:23     INFO -  Determining child pids from psutil
1763
14:41:23     INFO -  Found child pids: []
1764
14:41:23     INFO -  Killing process: 5192
1765
14:41:23     INFO -  TEST-INFO | started process screenshot
1766
14:41:23     INFO -  TEST-INFO | screenshot: exit 0
1767
14:41:23     INFO -  mozcrash Using Z:\task_1509028429\build\tests\bin\minidumpwriter.exe to write a dump to c:\users\genericworker\appdata\local\temp\tmpj6mmw0.mozrunner\minidumps\74df2a33-e9ad-41f6-8dfe-b208ddabb99f.dmp for [5192]
1768
14:47:51     INFO -  TEST-INFO | Main app process: exit 1
1769
14:47:51     INFO -  Buffered messages finished
1770
14:47:51    ERROR -  1 ERROR TEST-UNEXPECTED-FAIL | automation.py | application terminated with exit code 1


:jonco, could you please take a look?
Flags: needinfo?(jcoppeard)
Whiteboard: [stockwell needswork]
I looked at all the failure reports and only the first one is at GetGCThingMarkWordAndMask.  Most of the timeouts happen at NtWaitForMultipleObjects with some at AslHashFree and a few others.  Therefore I'm moving this out of the GC component and removing that signature from the title.  I don't know what's causing this but it seems to have spiked in the last day or two.
Component: JavaScript: GC → General
Flags: needinfo?(jcoppeard)
Product: Core → Testing
Summary: Intermittent TEST-UNEXPECTED-TIMEOUT | automation.py | application timed out after 330 seconds with no output [@ js::gc::detail::GetGCThingMarkWordAndMask] → Intermittent TEST-UNEXPECTED-TIMEOUT | automation.py | application timed out after 330 seconds with no output
Should we dup this to bug 1397201?
Flags: needinfo?(hskupin)
(In reply to Geoff Brown [:gbrown] from comment #7)
> Should we dup this to bug 1397201?

Yes, looks like the right type of action to do here.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(hskupin)
Resolution: --- → DUPLICATE
Duplicate of bug: 1397201
You need to log in before you can comment on or make changes to this bug.