Figure out how embedded apps can get their event loops serviced

VERIFIED DUPLICATE of bug 44678

Status

SeaMonkey
UI Design
P3
normal
VERIFIED DUPLICATE of bug 44678
19 years ago
13 years ago

People

(Reporter: travis, Assigned: dougt)

Tracking

({embed})

Trunk
x86
Windows NT
embed

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
When Gecko eventually gets embedded in another app, on some platforms it will
need the ability to have it's internal event loop serviced from the embedding
app.  On some platforms this is easy as the same event queue is always used
(Windows for instance).  On other platforms like Linux, you aren't sure the same
event queue will be used thus each one needs to be able to service it's own at
some point.
(Reporter)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M17

Comment 1

18 years ago
over to doug
Assignee: travis → dougt
Status: ASSIGNED → NEW
Keywords: embed
(Assignee)

Updated

18 years ago
Depends on: 44678
(Assignee)

Comment 2

18 years ago
dup.

*** This bug has been marked as a duplicate of 44678 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
Duplicate of other bug. The discussion there pretty much covers everything we
need to know. Marking as verified.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.