Closed Bug 1405459 Opened 4 years ago Closed 4 years ago

Question Marks in boxes instead of Text on Mac in Unicode English in 56.0 and 57.0b5 on Mac

Categories

(Firefox :: Untriaged, defect)

56 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1404919

People

(Reporter: jonahlee, Unassigned, NeedInfo)

Details

Attachments

(2 files)

Attached image Bing Search Results
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/604.1.38 (KHTML, like Gecko) Version/11.0 Safari/604.1.38

Steps to reproduce:

In both Firefox Developers Edition 57.0b5 and Firefox 56 (64 bit) on Mac OS X  many of my fonts are showing up as Question Marks in boxes. I am running MacOS Sierra 10.12.6 on a 5,1 MacPro with 32GB of RAM.


Actual results:

This did not happen before I installed these 2 version. Firefox was working just fine.


Expected results:

Normal fonts should have shown.
The workaround in the forum post at https://bugzilla.mozilla.org/show_bug.cgi?id=1404919#c1 worked for me. I was able to reduce my sandbox to 1 and that got rid of the problem.
Thanks for your confirmation! Marking as a duplicate then.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1404919
Jonah, to help us debug this, could you run the following command in the Terminal app (/Applications/Utilities/Terminal) and post the output to this bug or bug 1404919?

  system_profiler SPFontsDataType|grep Location|awk -F . '{print $NF}'|sort|uniq -c

More info on https://bugzilla.mozilla.org/show_bug.cgi?id=1404919#c7

Thanks!
Flags: needinfo?(jonahlee)
You need to log in before you can comment on or make changes to this bug.