Closed Bug 1405624 Opened 2 years ago Closed 2 years ago

Seach result tooltip overlaps other parts of the UI

Categories

(Firefox :: Preferences, defect, P3)

57 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox57 --- verified
firefox58 --- verified

People

(Reporter: nachtigall, Assigned: rickychien)

Details

(Whiteboard: [photon-preference])

Attachments

(3 files)

STR:
====
Go to preferences and type into the search input "Login" (or just "Log"). FWIW, I tried to find "Saved Logins" to copy a password.

AR:
===
The "Login" tooltip overlaps other parts of the UI which cannot be read anymore. See screenshot.

ER:
===
Dunno, but the tooltip should help the user and not make it harder to find what I am looking for.
Note that the tooltip does fade out when you mouseover it. But I agree it would take someone to mouse over the tooltip, as well if someone tries clicking on the tooltip the clicks don't go through the tooltip to the button behind it.

Evan / Tina, can you make sure UX takes a look at this. I know it is implemented as designed but this is making usability harder.
Flags: needinfo?(thsieh)
Flags: needinfo?(evan)
Priority: -- → P3
Whiteboard: [photon-preference][triage]
Sure, I will discuss the better UX design with Tina when she is back (currently she is on PTO).

I'm not sure, but maybe making the opacity of tooltips as 0.5 by default could be a simple solution. Just like the "set-opacity-of-tooltip.png" attachment.
Whiteboard: [photon-preference][triage] → [photon-preference]
Assignee: nobody → rchien
Status: NEW → ASSIGNED
Flags: qe-verify+
QA Contact: hani.yacoub
Flags: needinfo?(thsieh)
Flags: needinfo?(evan)
Summary: Seach result tooltip overlaps other parts of the UI (=> unreadable → Seach result tooltip overlaps other parts of the UI
Add opacity to tooltips by default should work. From the visual perspective, I suggest setting the default opacity to maybe 0.85, so the readability of the text in the tooltip will be okay and still stand out.
Comment on attachment 8915523 [details]
Bug 1405624 - Add opacity to Preferences seach result tooltip

https://reviewboard.mozilla.org/r/186744/#review191792

::: browser/themes/shared/incontentprefs/preferences.inc.css
(Diff revision 1)
>    bottom: 36px;
> +  opacity: .85;
>  }
>  
> -.search-tooltip:hover,
> +.search-tooltip:hover {
> -.search-tooltip:hover::before {

Removed .search-tooltip:hover::before since it is useless.
Comment on attachment 8915523 [details]
Bug 1405624 - Add opacity to Preferences seach result tooltip

https://reviewboard.mozilla.org/r/186744/#review191868
Attachment #8915523 - Flags: review?(jaws) → review+
Pushed by rchien@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/876b36faeae2
Add opacity to Preferences seach result tooltip r=jaws
Comment on attachment 8915523 [details]
Bug 1405624 - Add opacity to Preferences seach result tooltip

Approval Request Comment
[Feature/Bug causing the regression]:
[User impact if declined]: minor, search-tooltip UI polish when using search in Preferences
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]:  see description
[List of other uplifts needed for the feature/fix]: no
[Is the change risky?]: minor 
[Why is the change risky/not risky?]: UI polish
[String changes made/needed]: none
Attachment #8915523 - Flags: approval-mozilla-beta?
Comment on attachment 8915523 [details]
Bug 1405624 - Add opacity to Preferences seach result tooltip

Photon polish, Beta57+
Attachment #8915523 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Base on comment 7 and comment 10, patches have been landed in fx57 and fx58.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Comment 7 is autoland, let's wait for autoland merges into m-c.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
https://hg.mozilla.org/mozilla-central/rev/876b36faeae2
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Build ID: 20171009220104
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

Verified as fixed on Firefox Nightly 58.0a1 and on Firefox Beta 57.0b7 on Windows 10 x 64, Windows 7 x32, Mac OS X 10.12 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.