Closed Bug 1405846 Opened 2 years ago Closed 2 years ago

Crash in java.lang.IndexOutOfBoundsException: setSpan (43 ... 45) ends beyond length 44 at android.text.SpannableStringBuilder.checkRange(SpannableStringBuilder.java)

Categories

(Firefox for Android :: Awesomescreen, defect, critical)

All
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1127855
Tracking Status
firefox58 --- affected

People

(Reporter: jchen, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-2c02ad51-6101-41c9-904d-724cf0171004.
=============================================================

> java.lang.IndexOutOfBoundsException: setSpan (43 ... 45) ends beyond length 44
> 	at android.text.SpannableStringBuilder.checkRange(SpannableStringBuilder.java:1271)
> 	at android.text.SpannableStringBuilder.setSpan(SpannableStringBuilder.java:690)
> 	at android.text.SpannableStringBuilder.setSpan(SpannableStringBuilder.java:683)
> 	at org.mozilla.gecko.home.BrowserSearch$9.format(BrowserSearch.java:1232)
> 	at org.mozilla.gecko.home.TwoLinePageRow.update(TwoLinePageRow.java:257)
> 	at org.mozilla.gecko.home.TwoLinePageRow.updateFromCursor(TwoLinePageRow.java:338)
> 	at org.mozilla.gecko.home.BrowserSearch$SearchAdapter.bindView(BrowserSearch.java:1203)
> 	at org.mozilla.gecko.home.MultiTypeCursorAdapter.getView(MultiTypeCursorAdapter.java:62)
>	...

Low volume crash but looks to be a real bug in text handling. Want to take a look, Julian?
Flags: needinfo?(walkingice0204)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 788482
This crash happens on home screen (unrelated to IME).
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Duplicate of this bug: 1406739
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1127855
Thanks to Jan. remove NI since I am already cc-ed in the duplicate bug.
Flags: needinfo?(walkingice0204)
You need to log in before you can comment on or make changes to this bug.