Firefox-56.0 32bit rendering bug after RDP reconnect on Win7

RESOLVED WORKSFORME

Status

()

defect
P3
normal
RESOLVED WORKSFORME
2 years ago
3 months ago

People

(Reporter: dmitry.ghost99, Unassigned, NeedInfo)

Tracking

({regression})

55 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 wontfix, firefox57 fix-optional, firefox58 wontfix, firefox59 wontfix)

Details

(Whiteboard: [gfx-noted])

Reporter

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36

Steps to reproduce:

1. Connect to Windows 7 Machine A over RDP from Machine B and run Firefox-56.0 
2. Connect to Windows 7 Machine A over RDP from some other Machine C
3. Try to press right mouse button somewhere on web page.


Actual results:

Right mouse button dialog, settings menu on top right corner and "close tabs" window stop appearing on screen. All other Firefox popups also does not renders on screen.
Only way to handle this is to restart Firefox after every RDP reconnect from another machine. You can reproduce this not only with official Microsoft RDP client, but also with FreeRDP client.

Tested with Microsoft official RDP client on Win7 and WinXP, FreeRDP-2.0.0 20170928 dev. Other combinations will probably will cause this bug too. Tested on multiple Windows 7 installations.


Expected results:

Everything should work.

Updated

2 years ago
Component: Untriaged → Graphics
Product: Firefox → Core
Thanks Dmitry.  Is this a recent regression or something that has been happening for a while?  Are there older versions of Firefox (e.g., 55) where this works?  I'm not sure how possible it would be to run mozregression in this setup to find out exactly which build of Firefox cause this, but if you can try, it would be great.

Also, can you tell if the popups don't appear, but are otherwise there (as in, you could select something from it, just can't see it), or if they aren't actually there.  It may not be possible to tell these two scenarios apart, but thought I'd ask.
Flags: needinfo?(dmitry.ghost99)
Priority: -- → P3
Whiteboard: [gfx-noted]
Reporter

Comment 2

2 years ago
(In reply to Milan Sreckovic [:milan] from comment #1)
> Thanks Dmitry.  Is this a recent regression or something that has been
> happening for a while?  Are there older versions of Firefox (e.g., 55) where
> this works?  I'm not sure how possible it would be to run mozregression in
> this setup to find out exactly which build of Firefox cause this, but if you
> can try, it would be great.
This regression is in stable releases about a month.
I have played with mozregression for a while and find out, that last good build was at 2017-04-17 and first build with bug was at 2017-04-18. Also I done bisection, tested some versions, answered questions, and here is end of output:

--------- log ---------
2017-10-05T20:08:33: DEBUG : Starting merge handling...
2017-10-05T20:08:33: DEBUG : Using url: https://hg.mozilla.org/integration/autoland/json-pushes?changeset=de2c3726bd368f53fd8a0be135e1c373c47a1f30&full=1
2017-10-05T20:08:34: DEBUG : Found commit message:
Bug 1356218 - Fix nsDeviceContext::GetDepth to use the information from the correct monitor. r=jfkthame

MozReview-Commit-ID: BQpm6y3Ayo4

2017-10-05T20:08:34: INFO : The bisection is done.
--------- end of log ---------

Testing method: switching between Windows 7 RDP client and FreeRDP-2.0.0 dev multiple times, with connecting to Win7 machine with mozregression on it.

> Also, can you tell if the popups don't appear, but are otherwise there (as
> in, you could select something from it, just can't see it), or if they
> aren't actually there.  It may not be possible to tell these two scenarios
> apart, but thought I'd ask.
That elements is not there, it's not invisible. When you press settings button on tor right corner of browser window, button is looks pressed, but menu is not there and you can't press buttons on it.
Also, when you press Alt key, the menu in top of window is also not work: you can press File, View, etc, but menus are also not there.
Flags: needinfo?(dmitry.ghost99)
Reporter

Comment 3

2 years ago
It's been some time, after I have provided required information.
Here is a little demonstration with three instances of Windows 7 on virtualbox as a proof of that problem do exist in latest builds: https://youtu.be/HYmz7pQolpU
As you can see, dialogs stop render normally after second RDP connection.
But there is no such problem with build 2017-04-17, it works fine after any number of RDP reconnections.
Jonathan, are we maybe not covering the double RDP scenario with the changes in bug 1356218?
Blocks: 1356218
Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(jfkthame)
Keywords: regression
Version: 56 Branch → 55 Branch

Comment 5

2 years ago
I'm also seeing this on reconnecting via RDP to 64-bit Windows 7.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

a year ago
Also experiencing this issue, both 32 and 64 bit versions.  Occurring across multiple systems in both Work/Corporate/Windows Domain environments and home environments.
Duplicate of this bug: 1448069
Duplicate of this bug: 1434635

Comment 10

9 months ago
This appears to be fixed, for me anyways, in the latest update.  :D :D

Comment 11

9 months ago
Yes. Accessing Windows 7  Firefox 51.0.2(64bit) from Gnome RDP no longer sees the reported issues. Thanks.

Comment 12

9 months ago
(In reply to Hiro from comment #11)
> Yes. Accessing Windows 7  Firefox 51.0.2(64bit) from Gnome RDP no longer
> sees the reported issues. Thanks.

Oops! I meant FF 61.0.2.

Likely fixed by bug 603903.

Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.