Closed Bug 1406226 Opened 4 years ago Closed 4 years ago

CRM/Email Marketing Request: AMO - Email to Developers with Thunderbird/SeaMonkey add-ons

Categories

(Marketing :: Email, task)

All
Other
task
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jorgev, Unassigned)

Details

+++ This bug was initially created as a clone of Bug #1396646 +++

>> Mozilla Team/Department
Add-ons Community Experience Team (ACE)
>> What kind of relationships are you looking to develop?
This is a non-newsletter, one-off email to a specific subset of add-on developers. 

We’re moving Thunderbird and SeaMonkey add-ons to a separate website. We want to inform developers about what they can expect in the coming months.

>> How will you nurture these relationships?
Email, blog post, social support, direct outreach
>> How will success be measured?
Delivering the message to as many affected developers as possible is sufficient.
>> What is the risk to not doing this?
Developers won't know about the plans for Thunderbird and may take actions that affect their migration to using the WebExtensions API.
>> What's the timeline for launch?
Looking to send this email during October. 

>> Any other info we should know?
- Doc with content and list info: https://docs.google.com/document/d/1OarJxgESvDjgCbhHr0OmKZ0emZAnnuixYUasQFwCHVc/edit?ts=59d55c7c#

- we need to file a bug for legal review
Thanks, Jorge! I just invited you to our next LCM intake mtg on Monday @ 9am PT in Michele Warther's Vidyo so we can talk next steps.
P.S. I'll be taking over for Jessilyn while she's out on maternity leave. I look forward to meeting you! :) Do you mind cc'ing me on the Legal bug for reference?
Flags: needinfo?(jorge)
Done.
Flags: needinfo?(jorge)
Thanks for chatting yesterday, Jorge! Appreciate you tagging me in on that legal bug too.

Notes from our meeting can be found here:
https://docs.google.com/document/d/1hB-PHqLmWhjsoxmbP5Y-Tt0R6YqXoiy9cpmDcYrVhSA/edit#

We've added this project to our LCM backlog to try to work it in to our upcoming sprint. We'll keep you posted once it gets prioritized. Let us know if you have any questions in the meantime!
Hi Jorge, I wanted to let you know that this effort has been prioritized on our current sprint board! I just sent you/Brian a few questions in the Copy doc; once confirmed we'll get an email proof sent your way for review. Thanks!
Flags: needinfo?(jorge)
Done. Sorry for taking so long, but I've been out for a couple of weeks.
Flags: needinfo?(jorge)
Email proof was approved by Pseeger & Jorge.

Send is scheduled to go out tomorrow morning, 11/21 at 8:05am PT to the de-duped Thunderbird & SeaMonkey Developers salesforce report (~669)

I'll circle back once I've confirmed the email goes out successfully.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Email went out to 654; performance stats will be sent out via email tomorrow.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.