Closed Bug 1406374 Opened 3 years ago Closed 3 months ago

[sync] Source string changes not synced if pushed between repository pulls

Categories

(Webtools :: Pontoon, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mathjazz, Assigned: vishalcr7)

References

Details

(Whiteboard: pontoon-sync-join-tasks )

Attachments

(1 file)

Steps to reproduce:

1. Trigger sync for any project that uses a single repository for source strings and translations.

2. Push source string changes to repository after the repository is pulled and before set_last_synced_revisions() is called in sync_translations().

3. Wait for the sync_translations() task to complete.

4. Sync project again.

Expected outcome: Pushed source string changes are synced.

Actual outcome: Pushed source string changes are ignored and need to be force synced.

--

The problem is caused because the last_synced_revisions for the repository gets set to the commit ID which already contains the source changes. Hence, on next sync, Pontoon syncs only changesets that follow this commit ID.
Assignee: nobody → vishaliitr7
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Whiteboard: pontoon-sync-join-tasks
You need to log in before you can comment on or make changes to this bug.