Closed Bug 1406405 Opened 2 years ago Closed 2 years ago

Update pdf.js to version 1.9.630

Categories

(Firefox :: PDF Viewer, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 58
Tracking Status
firefox58 --- fixed

People

(Reporter: RyanVM, Assigned: RyanVM)

References

Details

+++ This bug was initially created as a clone of Bug #1404428 +++

Changes since last update:
#8976 Simplify the disabling of Node polyfills, in `gulpfile.js`, since we're now using Webpack 3.x
#8971 Closes all promises/streams when handler is destroyed.
#8979 Transform Web Archive URLs to avoid downloading an HTML page instead of the PDF file
#8977 Update all packages to the most recent version
#8981 Update translations
#8983 Remove unused helper code
#8980 Add CDN links
#8990 Added component example for single page viewer
#8994 Fix a regression that (effectively) makes `PDFHistory.forward` a no-op
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c1c3cb16a29b
Update pdf.js to version 1.9.628. r=bdahl
Backed out for frequently failing browser/extensions/pdfjs/test/browser_pdfjs_main.js:

https://hg.mozilla.org/integration/mozilla-inbound/rev/073b52890be1f0af93245d2697de1dfa464ec96a

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=135376354&repo=mozilla-inbound
16:13:35     INFO -  691 INFO TEST-PASS | browser/extensions/pdfjs/test/browser_pdfjs_main.js | pdf handler defaults to always-ask is false -
16:13:35     INFO -  692 INFO TEST-PASS | browser/extensions/pdfjs/test/browser_pdfjs_main.js | pdf handler defaults to internal -
16:13:35     INFO -  693 INFO Pref action: 3
16:13:35     INFO -  Buffered messages logged at 16:13:34
16:13:35     INFO -  694 INFO Console message: [JavaScript Warning: "Unknown pseudo-class or pseudo-element ‘selection’.  Ruleset ignored due to bad selector." {file: "resource://pdf.js/web/viewer.css" line: 60}]
16:13:35     INFO -  695 INFO Console message: [JavaScript Warning: "Unknown property ‘appearance’.  Declaration dropped." {file: "resource://pdf.js/web/viewer.css" line: 210}]
16:13:35     INFO -  696 INFO Console message: [JavaScript Warning: "Unknown pseudo-class or pseudo-element ‘selection’.  Ruleset ignored due to bad selector." {file: "resource://pdf.js/web/viewer.css" line: 1532}]
16:13:35     INFO -  Buffered messages logged at 16:13:35
16:13:35     INFO -  697 INFO TEST-PASS | browser/extensions/pdfjs/test/browser_pdfjs_main.js | Browser FindBar initialized! -
16:13:35     INFO -  698 INFO TEST-PASS | browser/extensions/pdfjs/test/browser_pdfjs_main.js | document content has viewer UI - {} == true -
16:13:35     INFO -  699 INFO TEST-PASS | browser/extensions/pdfjs/test/browser_pdfjs_main.js | window content has PDFJS object - true == true -
16:13:35     INFO -  700 INFO TEST-PASS | browser/extensions/pdfjs/test/browser_pdfjs_main.js | sidebar opens on click - true == true -
16:13:35     INFO -  701 INFO TEST-PASS | browser/extensions/pdfjs/test/browser_pdfjs_main.js | sidebar closes on click - true == true -
16:13:35     INFO -  702 INFO TEST-PASS | browser/extensions/pdfjs/test/browser_pdfjs_main.js | initial page is 1 - 1 == 1 -
16:13:35     INFO -  703 INFO TEST-PASS | browser/extensions/pdfjs/test/browser_pdfjs_main.js | viewBookmark button has href - true == true -
16:13:35     INFO -  Buffered messages finished
16:13:35    ERROR -  704 INFO TEST-UNEXPECTED-FAIL | browser/extensions/pdfjs/test/browser_pdfjs_main.js | A promise chain failed to handle a rejection: Worker was destroyed - stack: null
16:13:35     INFO -  Rejection date: Fri Oct 06 2017 16:13:35 GMT+0000 (Coordinated Universal Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 265
16:13:35     INFO -  Stack trace:
16:13:35     INFO -      resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:265
16:13:35     INFO -      chrome://mochikit/content/browser-test.js:Tester_execTest/<:829
16:13:35     INFO -      Tester_execTest@chrome://mochikit/content/browser-test.js:798:9
16:13:35     INFO -      Tester.prototype.nextTest</<@chrome://mochikit/content/browser-test.js:697:9
16:13:35     INFO -      SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59
16:13:35     INFO -  705 INFO Leaving test bound test
Flags: needinfo?(ryanvm)
Dammit, I should have seen that coming. Had the exact same failures on the Try push I'd done on top of Beta over in bug 1397557 for PR #8971. Brendan, can you please back that out upstream for now so I can get this sync done at least?
Flags: needinfo?(ryanvm) → needinfo?(bdahl)
Merged the revert.
Flags: needinfo?(bdahl)
Thanks.

Changes since last update:
#9002 Revert "Closes all promises/streams when handler is destroyed."
Summary: Update pdf.js to version 1.9.628 → Update pdf.js to version 1.9.630
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5d48c813ed7a
Update pdf.js to version 1.9.630. r=bdahl
https://hg.mozilla.org/mozilla-central/rev/5d48c813ed7a
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Blocks: 1408441
You need to log in before you can comment on or make changes to this bug.